summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRoel Janssen <roel@gnu.org>2016-05-23 11:09:13 +0200
committerLeo Famulari <leo@famulari.name>2016-05-23 12:36:38 -0400
commit031cf6b65e5e28d47e400e81db629f4431a2200e (patch)
tree3e88455d43ed800d338bb2f4fe489ee99a1f38c0 /gnu
parent148e8e8e7544b33cf655c9b97407a8d00ef58396 (diff)
downloadguix-patches-031cf6b65e5e28d47e400e81db629f4431a2200e.tar
guix-patches-031cf6b65e5e28d47e400e81db629f4431a2200e.tar.gz
gnu: Add r-zoo.
* gnu/packages/statistics.scm (r-zoo): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 43f9042e9c..1a6644391f 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -2617,6 +2617,26 @@ noncentral hypergeometric distribution (also called extended hypergeometric
distribution).")
(license license:gpl3+)))
+(define-public r-zoo
+ (package
+ (name "r-zoo")
+ (version "1.7-13")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "zoo" version))
+ (sha256
+ (base32
+ "0m67bnrg7r1jxvs9p7rpa430szp5qfp65r056yb8bivpc16jd98c"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-lattice" ,r-lattice)))
+ (home-page "http://zoo.R-Forge.R-project.org/")
+ (synopsis "S3 infrastructure for regular and irregular time series")
+ (description "This package contains an S3 class with methods for totally
+ordered indexed observations. It is particularly aimed at irregular time
+series of numeric vectors/matrices and factors.")
+ (license license:gpl2+)))
+
(define-public r-ztable
(package
(name "r-ztable")