summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-28 22:31:09 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-11-28 22:31:09 +0100
commitf18a586a45efe8447b3ef0c3c8df93e463630e9d (patch)
tree6fb092e9ab1df0120841bc9896a907872c6a3b6f /gnu
parente765ad091d861c99eae9fdd402214a2e2e90ed4d (diff)
downloadguix-patches-f18a586a45efe8447b3ef0c3c8df93e463630e9d.tar
guix-patches-f18a586a45efe8447b3ef0c3c8df93e463630e9d.tar.gz
gnu: pipewire-0.3: Update to 0.3.40.
* gnu/packages/linux.scm (pipewire-0.3): Update to 0.3.40. [arguments]: Disable session managers to avoid missing input.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d8e6c7dfa3..3fe36cb9e7 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -8190,7 +8190,7 @@ of Linux application development.")
(package
(inherit pipewire)
(name "pipewire")
- (version "0.3.29")
+ (version "0.3.40")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -8199,12 +8199,13 @@ of Linux application development.")
(file-name (git-file-name name version))
(sha256
(base32
- "16jjxcnahxqfcawz77ywx837ybhwzcivn7hgqb9cmlp1y2syy8gk"))))
+ "1c6gni23l5w3ghwqnfs712kjj6l1825f0ib8a6r2xc1ymr0sx3kr"))))
(arguments
'(#:configure-flags
(list (string-append "-Dudevrulesdir=" (assoc-ref %outputs "out")
"/lib/udev/rules.d")
- "-Dsystemd=disabled")
+ "-Dsystemd=disabled"
+ "-Dsession-managers=[]")
#:phases
(modify-phases %standard-phases
;; Skip shrink-runpath, otherwise validate-runpath fails.