summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-02-24 19:15:01 -0500
committerLeo Famulari <leo@famulari.name>2016-02-25 17:06:25 -0500
commit7dd21101a3be8c10674c1dc0ce40a842d7b0619c (patch)
tree1d1e3faf8072da2a97a363571ad930c3f8129935 /gnu
parent66d59111e3a6deeddd6b2e4f96a6c5440785532f (diff)
downloadguix-patches-7dd21101a3be8c10674c1dc0ce40a842d7b0619c.tar
guix-patches-7dd21101a3be8c10674c1dc0ce40a842d7b0619c.tar.gz
gnu: diffoscope: Update to 49.
* gnu/packages/package-management.scm (diffoscope): Update to 49. [source]: Use pypi-uri. [arguments]: Use python-3. Enable tests. Add 'dependency-on-python-magic' phase and remove 'dependency-on-rpm' phase. [native-inputs]: Remove python2-setuptools. [inputs]: Replace python2-file, python2-debian, python2-libarchive-c, python2-tlsh, python2-pytest, python2-chardet with python-3 variants.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/package-management.scm47
1 files changed, 19 insertions, 28 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 420a49eb28..ac6d84813f 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -389,21 +389,23 @@ transactions from C or Python.")
(define-public diffoscope
(package
(name "diffoscope")
- (version "34")
+ (version "49")
(source (origin
- (method git-fetch)
- (uri (git-reference
- (url
- "https://anonscm.debian.org/cgit/reproducible/diffoscope.git")
- (commit version)))
+ (method url-fetch)
+ (uri (pypi-uri name version))
(sha256
(base32
- "1g8b7bpkmns0355gkr3a244affwx4xzqwahwsl6ivw4z0qv7dih8"))
- (file-name (string-append name "-" version "-checkout"))))
+ "1mf6b7j82ckn90ggz6bp6c2jydz87xj8r8jmfl4hg7jcmf7dxmim"))))
(build-system python-build-system)
(arguments
- `(#:python ,python-2
- #:phases (modify-phases %standard-phases
+ `(#:phases (modify-phases %standard-phases
+ ;; setup.py mistakenly requires python-magic from PyPi, even
+ ;; though the Python bindings of `file` are sufficient.
+ ;; https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=815844
+ (add-after 'unpack 'dependency-on-python-magic
+ (lambda _
+ (substitute* "setup.py"
+ (("'python-magic',") ""))))
(add-before 'build 'disable-egg-zipping
(lambda _
;; Leave the .egg file uncompressed.
@@ -411,27 +413,16 @@ transactions from C or Python.")
(display "\n[easy_install]\nzip_ok = 0\n"
port)
(close-port port)
- #t)))
- (add-before 'build 'dependency-on-rpm
- (lambda _
- (substitute* "setup.py"
- ;; Somehow this requirement is reported as not met,
- ;; even though rpm.py is in the search path. So
- ;; delete it.
- (("'rpm-python',") ""))
- #t)))
- ;; FIXME: Some obscure test failures.
- #:tests? #f))
+ #t))))))
(inputs `(("rpm" ,rpm) ;for rpm-python
- ("python-file" ,python2-file)
- ("python-debian" ,python2-debian)
- ("python-libarchive-c" ,python2-libarchive-c)
- ("python-tlsh" ,python2-tlsh)
+ ("python-file" ,python-file)
+ ("python-debian" ,python-debian)
+ ("python-libarchive-c" ,python-libarchive-c)
+ ("python-tlsh" ,python-tlsh)
;; Below are modules used for tests.
- ("python-pytest" ,python2-pytest)
- ("python-chardet" ,python2-chardet)))
- (native-inputs `(("python-setuptools" ,python2-setuptools)))
+ ("python-pytest" ,python-pytest)
+ ("python-chardet" ,python-chardet)))
(home-page "http://diffoscope.org/")
(synopsis "Compare files, archives, and directories in depth")
(description