summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-02-25 12:50:10 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-02-25 21:05:37 +0200
commit6f068e081bd505a42a43ae09fad088dbe934a081 (patch)
treec36929b46e1781a2f98a9338e81b59207e0b4db8 /gnu
parentfee04c198c02ed318e59d9b0e7b48e238fe510ae (diff)
downloadguix-patches-6f068e081bd505a42a43ae09fad088dbe934a081.tar
guix-patches-6f068e081bd505a42a43ae09fad088dbe934a081.tar.gz
gnu: python-hypothesis: Update to 3.0.4.
* gnu/packages/python.scm (python-hypothesis): Update to 3.0.4. [native-inputs]: Remove python-setuptools. (python2-hypothesis): Use 'strip-python2-variant'. [native-inputs]: Add python2-enum34, python2-setuptools.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm17
1 files changed, 10 insertions, 7 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index fa1a51cce1..100bac0bee 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7535,17 +7535,14 @@ Amazon Web Services (AWS) API.")
(define-public python-hypothesis
(package
(name "python-hypothesis")
- (version "2.0.0")
+ (version "3.0.4")
(source (origin
(method url-fetch)
(uri (pypi-uri "hypothesis" version))
(sha256
(base32
- "1la6mfpvcn640gs2v35iv8b4sh6xdhp9j5ghay0jd86c9n4fkgxr"))))
+ "0bh6pqyc56cqlbpg0ffzjs6466blyylix4nsw11qrqwf01cg9gdq"))))
(build-system python-build-system)
- (native-inputs
- `(;; setuptools required for python-2 variant
- ("python-setuptools" ,python-setuptools)))
(propagated-inputs
`(("python-flake8" ,python-flake8)
("python-pytest" ,python-pytest)))
@@ -7555,10 +7552,16 @@ much larger range of examples than you would ever want to write by hand. It’s
based on the Haskell library, Quickcheck, and is designed to integrate
seamlessly into your existing Python unit testing work flow.")
(home-page "https://github.com/DRMacIver/hypothesis")
- (license mpl2.0)))
+ (license mpl2.0)
+ (properties `((python2-variant . ,(delay python2-hypothesis))))))
(define-public python2-hypothesis
- (package-with-python2 python-hypothesis))
+ (let ((hypothesis (package-with-python2
+ (strip-python2-variant python-hypothesis))))
+ (package (inherit hypothesis)
+ (native-inputs
+ `(("python2-enum34" ,python2-enum34)
+ ("python2-setuptools" ,python2-setuptools))))))
(define-public python-pytest-subtesthack
(package