summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-28 23:04:51 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-29 00:04:02 +0100
commit57b62e5bb9d85a5aca52cf1a3af6b0a22e6e649f (patch)
tree89916cee5811ce204d99620aa69652b264fbdd2a /gnu
parent8ecc99be11cfb7257f68b3a957500dc147567e81 (diff)
downloadguix-patches-57b62e5bb9d85a5aca52cf1a3af6b0a22e6e649f.tar
guix-patches-57b62e5bb9d85a5aca52cf1a3af6b0a22e6e649f.tar.gz
gnu: python2-requests: Remove dependency on python-charset-normalizer.
The python-charset-normalizer package is Python 3 only. * gnu/packages/python-web.scm (python-requests)[properties]: New field. (python2-requests): Rewrite to remove 'python-charset-normalizer' from 'propagated-inputs'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 5c9d57005b..98e3e6a8d5 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2547,10 +2547,17 @@ APIs.")
(description
"Requests is a Python HTTP client library. It aims to be easier to use
than Python’s urllib2 library.")
- (license license:asl2.0)))
+ (license license:asl2.0)
+ (properties `((python2-variant . ,(delay python2-requests))))))
(define-public python2-requests
- (package-with-python2 python-requests))
+ (let ((base (package-with-python2 (strip-python2-variant python-requests))))
+ (package
+ (inherit base)
+ ;; The python-charset-normalizer dependency is necessary on Python 3
+ ;; only.
+ (propagated-inputs (modify-inputs (package-propagated-inputs base)
+ (delete "python-charset-normalizer"))))))
(define-public python-requests-unixsocket
(package