summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-02-25 22:20:58 -0500
committerMark H Weaver <mhw@netris.org>2016-02-25 22:24:32 -0500
commit4ed737b2ab65c3af57a6774439d86b75140fbf34 (patch)
tree0fb10c198b658a6127ec0832c39075d186c7098b /gnu
parentb31fbea566d432ae8be616ac774d51a23436c362 (diff)
downloadguix-patches-4ed737b2ab65c3af57a6774439d86b75140fbf34.tar
guix-patches-4ed737b2ab65c3af57a6774439d86b75140fbf34.tar.gz
gnu: gtk-doc: Improve fix-docbook phase.
* gnu/packages/gtk.scm (gtk-doc)[arguments]: In the 'fix-docbook' phase, avoid hard-coding the docbook-xsl version number, and return #t.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gtk.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 9f2e514e14..4fb4e8dc0d 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1121,9 +1121,10 @@ information.")
;; docbook-xsl catalog explicitly and get on with life.
(("\"\\$XML_CATALOG_FILE\" \
\"http://docbook.sourceforge.net/release/xsl/")
- (string-append (assoc-ref %build-inputs "docbook-xsl")
- "/xml/xsl/docbook-xsl-1.78.1/catalog.xml \
-\"http://docbook.sourceforge.net/release/xsl/"))))))
+ (string-append (car (find-files (assoc-ref inputs "docbook-xsl")
+ "^catalog.xml$"))
+ " \"http://docbook.sourceforge.net/release/xsl/")))
+ #t)))
#:configure-flags
(list (string-append "--with-xml-catalog="
(assoc-ref %build-inputs "docbook-xml")