summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-01-25 15:34:23 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-01-28 15:07:55 +0100
commit6d3cafa086b380b371d093906390ad610170ff2b (patch)
treef27f12dd27080c0890d06e04cd9fe6d41465e0b4 /gnu
parent09ab0d42b00d38abb57dd8218062e797d5117080 (diff)
downloadguix-patches-6d3cafa086b380b371d093906390ad610170ff2b.tar
guix-patches-6d3cafa086b380b371d093906390ad610170ff2b.tar.gz
gnu: Add trf.
* gnu/packages/bioinformatics.scm (trf): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 8514306f94..1aa60a0ae7 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2822,6 +2822,30 @@ sequencing data. It uses paired-ends and split-reads to sensitively and
accurately delineate genomic rearrangements throughout the genome.")
(license license:gpl3+)))
+(define-public trf
+ (package
+ (name "trf")
+ (version "4.09.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Benson-Genomics-Lab/TRF")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0fhwr4s1mf8nw8fr5imwjvjr42b59p97zr961ifm8xl1bajz4wpg"))))
+ (build-system gnu-build-system)
+ (home-page "https://github.com/Benson-Genomics-Lab/TRF")
+ (synopsis "Tandem Repeats Finder: a program to analyze DNA sequences")
+ (description "A tandem repeat in DNA is two or more adjacent, approximate
+copies of a pattern of nucleotides. Tandem Repeats Finder is a program to
+locate and display tandem repeats in DNA sequences. In order to use the
+program, the user submits a sequence in FASTA format. The output consists of
+two files: a repeat table file and an alignment file. Submitted sequences may
+be of arbitrary length. Repeats with pattern size in the range from 1 to 2000
+bases are detected.")
+ (license license:agpl3+)))
+
(define-public diamond
(package
(name "diamond")