summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2022-03-18 12:56:28 -0400
committerLeo Famulari <leo@famulari.name>2022-03-18 12:58:05 -0400
commit386adb6df0e00e7170df0cdfaf0e04c38d0f3e11 (patch)
tree8078ca018e6d56880258ce08129c5ed385af37d8 /gnu
parent2fb4304ee7eb7d17d48bee345677ef1f288a0b86 (diff)
downloadguix-patches-386adb6df0e00e7170df0cdfaf0e04c38d0f3e11.tar
guix-patches-386adb6df0e00e7170df0cdfaf0e04c38d0f3e11.tar.gz
gnu: b2sum: Produce generic binaries and enable tuning.
* gnu/packages/crypto.scm (b2sum)[arguments]: Add 'de-tune' phase. [properties]: Mark the package as tunable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crypto.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index cf8bc111e1..63be51f86a 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -873,6 +873,11 @@ BLAKE.")
(add-before 'build 'change-directory
(lambda _
(chdir "b2sum")))
+ ;; Produce generic binaries
+ (add-after 'change-directory 'de-tune
+ (lambda _
+ (substitute* "makefile"
+ ((" -march=native") ""))))
(delete 'configure)))) ; No ./configure script
(home-page "https://www.blake2.net/")
(synopsis "BLAKE2 checksum tool")
@@ -880,7 +885,11 @@ BLAKE.")
SHA-1, SHA-2, and SHA-3, yet is at least as secure as SHA-3.")
;; You may also choose to redistribute this program as Apache 2.0 or the
;; OpenSSL license. See 'b2sum/b2sum.c' in the source distribution.
- (license license:cc0))))
+ (license license:cc0)
+ ;; There is a significant speedup when the compiler generates
+ ;; instructions tuned to the CPU of the running machine:
+ ;; https://debbugs.gnu.org/cgi/bugreport.cgi?bug=51198#22
+ (properties '((tunable? . #true))))))
(define-public rhash
(package