summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-05-16 21:31:12 +0200
committerAndreas Enge <andreas@enge.fr>2015-05-16 22:21:04 +0200
commit933c390ca7ab50d28a29c8e92dc81988af7a84d1 (patch)
treebb50e95c792b9798a3bd51abaa38e25e18e8b5f8 /gnu
parentb7e71faaf73e8cb9acc562561fd0051090d041e0 (diff)
downloadguix-patches-933c390ca7ab50d28a29c8e92dc81988af7a84d1.tar
guix-patches-933c390ca7ab50d28a29c8e92dc81988af7a84d1.tar.gz
gnu: libe-book: Propagate inputs.
* gnu/packages/libreoffice.scm (libe-book): Move icu4c, librevenge and libxml2 from 'inputs' to 'propagated-inputs'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/libreoffice.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index e285e5f897..fc0ca836fa 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -163,10 +163,12 @@ into other word processors.")
`(("cppunit" ,cppunit)
("gperf" ,gperf)
("pkg-config" ,pkg-config)))
- (inputs `(("boost" ,boost)
- ("icu4c" ,icu4c)
- ("librevenge" ,librevenge)
- ("libxml2" ,libxml2)))
+ (propagated-inputs ; in Requires or Requires.private field of .pkg
+ `(("icu4c" ,icu4c)
+ ("librevenge" ,librevenge)
+ ("libxml2" ,libxml2)))
+ (inputs
+ `(("boost" ,boost)))
(arguments
;; avoid triggering configure errors by simple inclusion of boost headers
`(#:configure-flags '("--disable-werror")))