summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-08-23 11:02:11 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-08-23 11:13:16 +0300
commit24cc25be893e43026730410fe0241b80386af610 (patch)
tree9fed9c6c17a03921ff5ac2f3e1b2e38f69d059e8 /gnu
parentd0fc1e832c3f403645e13b9b23929f3b463f6a31 (diff)
downloadguix-patches-24cc25be893e43026730410fe0241b80386af610.tar
guix-patches-24cc25be893e43026730410fe0241b80386af610.tar.gz
gnu: python-rpy2: Update to 3.3.5.
* gnu/packages/statistics.scm (python-rpy2): Update to 3.3.5. [source]: Add patches to fix test failures. [arguments]: Adjust custom 'check phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm145
1 files changed, 78 insertions, 67 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index f17d616494..bae80ab610 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -5683,76 +5683,87 @@ to any arbitrary string. In this case, it is up to you to set valid values.")
(license license:gpl3+)))
(define-public python-rpy2
- ;; We need to take this changeset instead of the RELEASE_3_0_4 tag, because
- ;; it fixes a regression when using ggplot 3.2.0.
- (let ((changeset "19868a8")
- (revision "1"))
- (package
- (name "python-rpy2")
- (version (git-version "3.0.4" revision changeset))
- (source
- (origin
- (method hg-fetch)
- (uri (hg-reference
- (url "https://bitbucket.org/rpy2/rpy2")
- (changeset changeset)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1bb0wslcbj3wjvyk3jb9yyzdi6adfqh5vfgcvn22dyzxzbhcs8kk"))))
- (build-system python-build-system)
- (arguments
- '(#:modules ((ice-9 ftw)
- (srfi srfi-1)
- (srfi srfi-26)
- (guix build utils)
- (guix build python-build-system))
- #:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key outputs inputs #:allow-other-keys)
- (let ((cwd (getcwd)))
- (setenv "TZ" "UTC")
- (setenv "PYTHONPATH"
- (string-append cwd "/build/"
- (find (cut string-prefix? "lib" <>)
- (scandir (string-append cwd "/build")))
- ":"
- (getenv "PYTHONPATH"))))
- (invoke "pytest" "-v" "rpy/tests/"))))))
- (propagated-inputs
- `(("python-cffi" ,python-cffi)
- ("python-six" ,python-six)
- ("python-jinja2" ,python-jinja2)
- ("python-numpy" ,python-numpy)
- ("python-pandas" ,python-pandas)
- ("python-pytz" ,python-pytz)
- ("python-ipython" ,python-ipython)
- ("python-tzlocal" ,python-tzlocal)))
- (inputs
- `(("readline" ,readline)
- ("icu4c" ,icu4c)
- ("pcre" ,pcre)
- ("r-minimal" ,r-minimal)
- ("r-survival" ,r-survival)
- ("r-ggplot2" ,r-ggplot2)
- ("r-rsqlite" ,r-rsqlite)
- ("r-dplyr" ,r-dplyr)
- ("r-dbplyr" ,r-dbplyr)
- ("python-numpy" ,python-numpy)))
- (native-inputs
- `(("zlib" ,zlib)
- ("python-pytest" ,python-pytest)))
- (home-page "https://rpy2.github.io")
- (synopsis "Python interface to the R language")
- (description "rpy2 is a redesign and rewrite of rpy. It is providing a
+ (package
+ (name "python-rpy2")
+ (version "3.3.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "rpy2" version))
+ (sha256
+ (base32
+ "1bs36rds5fq8821l5q85q2b25161rs9ppw5c26x0hjwj487gpcfj"))
+ ;; These patches should be removed with the next release.
+ (patches
+ (list
+ (origin
+ (method url-fetch)
+ (uri "https://github.com/rpy2/rpy2/commit/04c57598f00145d868ea8da31ac1b1e7c49f7570.patch")
+ (file-name "python-rpy2-fix-test-failure.patch")
+ (sha256
+ (base32
+ "1lqd3yxjfx1rxrybcmnapy0r6ambg9myrb98q4nlfhpxanwfdbbh")))
+ (origin
+ (method url-fetch)
+ (uri "https://github.com/rpy2/rpy2/commit/685f67d0a6b47ea80e718116a10755019446aef7.patch")
+ (file-name "python-rpy2-r-console-test-fix.patch")
+ (sha256
+ (base32
+ "18wpvfaa4c13d44cb4sw88c3c7403xdy5m8h82wfq8fjmcq3cmzn")))))))
+ (build-system python-build-system)
+ (arguments
+ '(#:modules ((ice-9 ftw)
+ (srfi srfi-1)
+ (srfi srfi-26)
+ (guix build utils)
+ (guix build python-build-system))
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key outputs inputs #:allow-other-keys)
+ (let ((cwd (getcwd)))
+ (setenv "TZ" "UTC")
+ (setenv "PYTHONPATH"
+ (string-append cwd "/build/"
+ (find (cut string-prefix? "lib" <>)
+ (scandir (string-append cwd "/build")))
+ ":"
+ (getenv "PYTHONPATH"))))
+ ;; test_vector_complex has issues when run in our environment.
+ (invoke "pytest" "-v" "rpy2/tests/" "-k" "not test_vector_complex"))))))
+ (propagated-inputs
+ `(("python-cffi" ,python-cffi)
+ ("python-six" ,python-six)
+ ("python-jinja2" ,python-jinja2)
+ ("python-numpy" ,python-numpy)
+ ("python-pandas" ,python-pandas)
+ ("python-pytz" ,python-pytz)
+ ("python-ipython" ,python-ipython)
+ ("python-tzlocal" ,python-tzlocal)))
+ (inputs
+ `(("readline" ,readline)
+ ("icu4c" ,icu4c)
+ ("pcre" ,pcre)
+ ("r-minimal" ,r-minimal)
+ ("r-survival" ,r-survival)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-rsqlite" ,r-rsqlite)
+ ("r-dplyr" ,r-dplyr)
+ ("r-dbplyr" ,r-dbplyr)
+ ("python-numpy" ,python-numpy)))
+ (native-inputs
+ `(("zlib" ,zlib)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://rpy2.github.io")
+ (synopsis "Python interface to the R language")
+ (description "rpy2 is a redesign and rewrite of rpy. It is providing a
low-level interface to R from Python, a proposed high-level interface,
including wrappers to graphical libraries, as well as R-like structures and
functions.")
- ;; Any of these licenses can be picked for the R interface. The whole
- ;; project is released under GPLv2+ according to the license declaration
- ;; in "setup.py".
- (license (list license:mpl2.0 license:gpl2+ license:lgpl2.1+)))))
+ ;; Any of these licenses can be picked for the R interface. The whole
+ ;; project is released under GPLv2+ according to the license declaration
+ ;; in "setup.py".
+ (license (list license:mpl2.0 license:gpl2+ license:lgpl2.1+))))
(define-public java-jdistlib
(package