summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-03-12 00:14:00 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-03-17 10:14:00 +0100
commite88bad6ddb5a230a34acff2577ee24af95f0ac12 (patch)
tree88b2af15eefd3fcdaf6fba09940d1f0d15478f99 /gnu
parent69fddd2d6e4c77ea39640ebb85ec306a26e5b3c1 (diff)
downloadguix-patches-e88bad6ddb5a230a34acff2577ee24af95f0ac12.tar
guix-patches-e88bad6ddb5a230a34acff2577ee24af95f0ac12.tar.gz
gnu: Add r-kernsmooth.
* gnu/packages/statistics.scm (r-kernsmooth): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 2317b37c38..0b092ed153 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -342,6 +342,28 @@ some versions of Epi Info, Minitab, S, SAS, SPSS, Stata, Systat and Weka and
for reading and writing some dBase files.")
(license license:gpl2+)))
+(define-public r-kernsmooth
+ (package
+ (name "r-kernsmooth")
+ (version "2.23-15")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "KernSmooth" version))
+ (sha256
+ (base32
+ "1xhha8kw10jv8pv8b61hb5in9qiw3r2a9kdji3qlm991s4zd4wlb"))))
+ (properties `((upstream-name . "KernSmooth")))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/KernSmooth")
+ (synopsis "Functions for kernel smoothing")
+ (description
+ "This package provides functions for kernel smoothing (and density
+estimation) corresponding to the book: Wand, M.P. and Jones, M.C. (1995)
+\"Kernel Smoothing\".")
+ ;; Unlimited distribution
+ (license (license:non-copyleft "file://LICENCE.note"))))
+
(define-public r-bit
(package
(name "r-bit")