summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-03-12 00:15:44 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-03-17 10:14:01 +0100
commit69e14f9ec756996e4e4dbcb57444cdb7ac1a642b (patch)
tree50bce6307ae1a907226d259bad3c72e7562618b6 /gnu
parent060c12868bb232c5275a76ceabb3a966b04bf7a6 (diff)
downloadguix-patches-69e14f9ec756996e4e4dbcb57444cdb7ac1a642b.tar
guix-patches-69e14f9ec756996e4e4dbcb57444cdb7ac1a642b.tar.gz
gnu: r-matrix: Move to set of recommended R packages.
* gnu/packages/statistics.scm (r-matrix): Move to set of recommended R packages.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm44
1 files changed, 22 insertions, 22 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 0fa3be42cc..23d6c9392b 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -384,6 +384,28 @@ multivariate data. Lattice is sufficient for typical graphics needs, and is
also flexible enough to handle most nonstandard requirements.")
(license license:gpl2+)))
+(define-public r-matrix
+ (package
+ (name "r-matrix")
+ (version "1.2-7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "Matrix" version))
+ (sha256
+ (base32
+ "09rd51na9spz0lm1lylkfhw43w7c922b83m4jsggmpg3pbd6dssa"))))
+ (properties `((upstream-name . "Matrix")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-lattice" ,r-lattice)))
+ (home-page "http://Matrix.R-forge.R-project.org/")
+ (synopsis "Sparse and dense matrix classes and methods")
+ (description
+ "This package provides classes and methods for dense and sparse matrices
+and operations on them using LAPACK and SuiteSparse.")
+ (license license:gpl2+)))
+
(define-public r-bit
(package
(name "r-bit")
@@ -623,28 +645,6 @@ and Francois (2011, JSS), and the book by Eddelbuettel (2013, Springer); see
'citation(\"Rcpp\")' for details on these last two.")
(license license:gpl2+)))
-(define-public r-matrix
- (package
- (name "r-matrix")
- (version "1.2-7.1")
- (source
- (origin
- (method url-fetch)
- (uri (cran-uri "Matrix" version))
- (sha256
- (base32
- "09rd51na9spz0lm1lylkfhw43w7c922b83m4jsggmpg3pbd6dssa"))))
- (properties `((upstream-name . "Matrix")))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-lattice" ,r-lattice)))
- (home-page "http://Matrix.R-forge.R-project.org/")
- (synopsis "Sparse and dense matrix classes and methods")
- (description
- "This package provides classes and methods for dense and sparse matrices
-and operations on them using LAPACK and SuiteSparse.")
- (license license:gpl2+)))
-
(define-public r-mgcv
(package
(name "r-mgcv")