summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-10 18:08:33 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-10 18:50:01 +0100
commit5a457656284cfb25e9305362e18adf4aff13f91a (patch)
tree4509ce47ac0e6f4646cb67c3314b3f3cc3158ecb /gnu
parente1e89e2628b754da7823274d46bdef2a49539ca7 (diff)
downloadguix-patches-5a457656284cfb25e9305362e18adf4aff13f91a.tar
guix-patches-5a457656284cfb25e9305362e18adf4aff13f91a.tar.gz
gnu: python-mako: Fix FTBFS with Pytest 4.
* gnu/packages/python-xyz.scm (python-mako)[arguments]: New field.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bf2fc56294..9749ce96bb 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8000,6 +8000,14 @@ python-xdo for newer bindings.)")
(base32
"1bi5gnr8r8dva06qpyx4kgjc6spm2k1y908183nbbaylggjzs0jf"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'patch-setup.cfg
+ (lambda _
+ ;; Adjust setup.cfg for compatibility with Pytest 4.
+ (substitute* "setup.cfg"
+ (("\\[pytest\\]") "[tool:pytest]"))
+ #t)))))
(propagated-inputs
`(("python-markupsafe" ,python-markupsafe)))
(native-inputs