summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-04 15:31:59 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-06-04 15:31:59 +0200
commit3d8496705d5c4aa3c7253750dbc93ec513e94ffe (patch)
treef2eaabe3032f3dff2c6d177cfce3dc5c9d86bdd4 /gnu
parent398ec3c1e265a3f89ed07987f33b264db82e4080 (diff)
downloadguix-patches-3d8496705d5c4aa3c7253750dbc93ec513e94ffe.tar
guix-patches-3d8496705d5c4aa3c7253750dbc93ec513e94ffe.tar.gz
gnu: emacs-nov-el: Add comment about upstream not tagging releases.
* gnu/packages/emacs-xyz.scm (emacs-nov-el): Add a comment. Fix indentation.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm65
1 files changed, 34 insertions, 31 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8b06ead381..1f509a37a9 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12426,36 +12426,39 @@ the format.")
(license license:gpl3+)))
(define-public emacs-nov-el
- (package
- (name "emacs-nov-el")
- (version "0.3.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://depp.brause.cc/nov.el.git")
- (commit "ea0c835c1b5e6e70293f4bd64e9c89bdc42f8596")))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "04phmm14ywgicjsl2bsg6w9rapd71vdkxdp5wp0brj6px27y85jz"))))
- (build-system emacs-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'embed-path-to-unzip
- (lambda _
- (substitute* "nov.el"
- (("\\(executable-find \"unzip\"\\)")
- (string-append "\"" (which "unzip") "\"")))
- #t)))))
- (propagated-inputs
- `(("emacs-dash" ,emacs-dash)
- ("emacs-esxml" ,emacs-esxml)))
- (inputs
- `(("unzip" ,unzip)))
- (home-page "https://depp.brause.cc/nov.el/")
- (synopsis "Major mode for reading EPUBs in Emacs")
- (description "@code{nov.el} provides a major mode for reading EPUB
+ ;; Upstream does not tag releases. Specify raw commit hash matching the
+ ;; release.
+ (let ((commit "ea0c835c1b5e6e70293f4bd64e9c89bdc42f8596"))
+ (package
+ (name "emacs-nov-el")
+ (version "0.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://depp.brause.cc/nov.el.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "04phmm14ywgicjsl2bsg6w9rapd71vdkxdp5wp0brj6px27y85jz"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'embed-path-to-unzip
+ (lambda _
+ (substitute* "nov.el"
+ (("\\(executable-find \"unzip\"\\)")
+ (string-append "\"" (which "unzip") "\"")))
+ #t)))))
+ (propagated-inputs
+ `(("emacs-dash" ,emacs-dash)
+ ("emacs-esxml" ,emacs-esxml)))
+ (inputs
+ `(("unzip" ,unzip)))
+ (home-page "https://depp.brause.cc/nov.el/")
+ (synopsis "Major mode for reading EPUBs in Emacs")
+ (description "@code{nov.el} provides a major mode for reading EPUB
documents.
Features:
@@ -12472,7 +12475,7 @@ Features:
@item Image rescaling
@end itemize
")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public epipe
(package