summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-27 15:50:26 +0200
committerMarius Bakke <marius@gnu.org>2020-06-27 20:08:23 +0200
commitdb10d94dcd920f55c133352e677ebd68eb6fc436 (patch)
treee39b0aeb16dc2089240c6ace498a9c15a952fb73 /gnu
parentedeb6f17f2df9d3bdf29cc9c0486e51e652c33ed (diff)
downloadguix-patches-db10d94dcd920f55c133352e677ebd68eb6fc436.tar
guix-patches-db10d94dcd920f55c133352e677ebd68eb6fc436.tar.gz
gnu: Add python2-selectors2.
* gnu/packages/python-xyz.scm (python2-selectors2): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 300277f045..2912d9a723 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11343,6 +11343,29 @@ functionality in a modular way, allowing you to extend your panel with your
own code, responding to click events and updating clock every second.")
(license license:bsd-3)))
+(define-public python2-selectors2
+ (package
+ (name "python2-selectors2")
+ (version "2.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "selectors2" version))
+ (sha256
+ (base32
+ "110qr00b9axz1f1jm12b495jkvrz80smknxvssqlhwk0dx67rdw1"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2))
+ (native-inputs
+ `(("python2-mock" ,python2-mock)
+ ("python2-psutil" ,python2-psutil)))
+ (home-page "https://www.github.com/SethMichaelLarson/selectors2")
+ (synopsis "Backport of the selectors module from Python 3.5+")
+ (description
+ "This package provides a drop-in replacement for the @code{selectors}
+module in Python 3.5 and later.")
+ (license license:expat)))
+
(define-public python-tblib
(package
(name "python-tblib")