summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-07 17:18:28 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-07 18:44:04 +0100
commitd53b23176f3da88a9aea922f44abc03ceb2c7ecb (patch)
tree94c13220bd3cc915cd130f8372aaf18fbe866b15 /gnu
parente3bb076678aa25b5394b4d35c38aaa3607065082 (diff)
downloadguix-patches-d53b23176f3da88a9aea922f44abc03ceb2c7ecb.tar
guix-patches-d53b23176f3da88a9aea922f44abc03ceb2c7ecb.tar.gz
gnu: Add r-corpcor.
* gnu/packages/cran.scm (r-corpcor): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 02fe328318..847e3ccacb 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -8852,3 +8852,25 @@ intrinsic structure of single cell genomics data. In general, it could be
used to reconstruct the temporal progression as well as the bifurcation
structure of any data type.")
(license license:asl2.0)))
+
+(define-public r-corpcor
+ (package
+ (name "r-corpcor")
+ (version "1.6.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "corpcor" version))
+ (sha256
+ (base32
+ "1hi3i9d3841snppq1ks5pd8cliq1b4rm4dpsczmfqvwksg8snkrf"))))
+ (build-system r-build-system)
+ (home-page "http://strimmerlab.org/software/corpcor/")
+ (synopsis "Efficient estimation of covariance and (partial) correlation")
+ (description
+ "This package implements a James-Stein-type shrinkage estimator for the
+covariance matrix, with separate shrinkage for variances and correlations.
+Furthermore, functions are available for fast singular value decomposition,
+for computing the pseudoinverse, and for checking the rank and positive
+definiteness of a matrix.")
+ (license license:gpl3+)))