summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-07 16:26:54 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-07 18:44:04 +0100
commit13f5837b4ce12aca681b15e985738f95c4045ad5 (patch)
treef4ca3f7935b5de5f374990cfe791a41b9cadf974 /gnu
parentb614009e6a8c965ef73d8d65e99d44b933f9eb12 (diff)
downloadguix-patches-13f5837b4ce12aca681b15e985738f95c4045ad5.tar
guix-patches-13f5837b4ce12aca681b15e985738f95c4045ad5.tar.gz
gnu: Add r-densityclust.
* gnu/packages/cran.scm (r-densityclust): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 9aa6e3b270..4ffcdbab36 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -8747,3 +8747,33 @@ only sparse real matrices in Matrix package format are supported.")
;; SVDLIBC is released under BSD-2. The R interface is released under
;; BSD-3.
(license (list license:bsd-3 license:bsd-2))))
+
+(define-public r-densityclust
+ (package
+ (name "r-densityclust")
+ (version "0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "densityClust" version))
+ (sha256
+ (base32
+ "1zry0vafajzmr37aylglxfvwplhdygbkb9cvzvh8cy0xgnjrnx13"))))
+ (properties `((upstream-name . "densityClust")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-fnn" ,r-fnn)
+ ("r-ggplot2" ,r-ggplot2)
+ ("r-ggrepel" ,r-ggrepel)
+ ("r-gridextra" ,r-gridextra)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rtsne" ,r-rtsne)))
+ (home-page "https://cran.r-project.org/web/packages/densityClust")
+ (synopsis "Clustering by fast search and find of density peaks")
+ (description
+ "This package provides an improved implementation (based on k-nearest
+neighbors) of the density peak clustering algorithm, originally described by
+Alex Rodriguez and Alessandro Laio (Science, 2014 vol. 344). It can handle
+large datasets (> 100,000 samples) very efficiently.")
+ (license license:gpl2+)))