summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-10 10:20:01 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-10 14:04:28 +0100
commitc06709b8a496c2af91562ee8bfba538b51ec6c35 (patch)
tree0637bd153fec54c5938e8a70add4deb050b4dd2e /gnu
parent05487ed8e629b057a113c18560c5976a81c88237 (diff)
downloadguix-patches-c06709b8a496c2af91562ee8bfba538b51ec6c35.tar
guix-patches-c06709b8a496c2af91562ee8bfba538b51ec6c35.tar.gz
gnu: Add slingshot.
* gnu/packages/games.scm (slingshot): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 0d50f55a75..0dcf7eb879 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -6118,3 +6118,30 @@ to download and install them in @file{$HOME/.stepmania-X.Y/Songs} directory.")
(home-page "https://www.stepmania.com")
(license license:expat)))
+
+(define-public slingshot
+ (package
+ (name "slingshot")
+ (version "0.9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ryanakca/slingshot.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "19m8b6nsi786bc6gmkp185mwri3r5y249gjmqd5qsc23nnfhgrs1"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2))
+ (inputs
+ `(("python-pygame" ,python2-pygame)))
+ (home-page "https://github.com/ryanakca/slingshot")
+ (synopsis "Simple 2D shooting strategy game set in space")
+ (description "Slingshot is a two-dimensional strategy game where two
+players attempt to shoot one another through a section of space populated by
+planets. The main feature of the game is that the shots, once fired, are
+affected by the gravity of the planets.")
+ (license license:gpl2+)))