summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-10 09:38:03 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-10 14:04:28 +0100
commit05487ed8e629b057a113c18560c5976a81c88237 (patch)
tree78fc69f32b1f406faf9104ad16740c5aa76d3e39 /gnu
parent4eb57ca883e804897f7099ecf6e5a77161e46d9e (diff)
downloadguix-patches-05487ed8e629b057a113c18560c5976a81c88237.tar
guix-patches-05487ed8e629b057a113c18560c5976a81c88237.tar.gz
gnu: scons: Update to 3.0.4.
* gnu/packages/python-xyz.scm (scons): Update to 3.0.4. [arguments]: Remove second instance of "imp.load_module" (bug 34236).
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2ec12be007..db4a2e0193 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1355,7 +1355,7 @@ existing ones.")
(define-public scons
(package
(name "scons")
- (version "3.0.3")
+ (version "3.0.4")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -1364,7 +1364,7 @@ existing ones.")
(file-name (git-file-name name version))
(sha256
(base32
- "1xizkjgrvydkjhpv7i5rx0mdkp3618sis7jsckjh57nxcynlk5dc"))))
+ "1xy8jrwz87y589ihcld4hv7wn122sjbz914xn8h50ww77wbhk8hn"))))
(build-system python-build-system)
(arguments
`(#:use-setuptools? #f ; still relies on distutils
@@ -1376,6 +1376,9 @@ existing ones.")
(substitute* "src/engine/SCons/compat/__init__.py"
(("sys.modules\\[new\\] = imp.load_module\\(old, \\*imp.find_module\\(old\\)\\)")
"sys.modules[new] = __import__(old)"))
+ (substitute* "src/engine/SCons/Platform/__init__.py"
+ (("mod = imp.load_module\\(full_name, file, path, desc\\)")
+ "mod = __import__(full_name)"))
(invoke "python" "bootstrap.py" "build/scons" "DEVELOPER=guix")
(chdir "build/scons")
#t)))))