summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-09-06 23:26:00 +0200
committerLudovic Courtès <ludo@gnu.org>2014-09-06 23:42:56 +0200
commit1456cff18fa38c57729fd3d91c200a113cbaed59 (patch)
tree4a2898bc99155350b10bdff06dce2dbec7d28af7 /gnu
parentb53833b2ef36cf139f65193bec688396a734b0d0 (diff)
downloadguix-patches-1456cff18fa38c57729fd3d91c200a113cbaed59.tar
guix-patches-1456cff18fa38c57729fd3d91c200a113cbaed59.tar.gz
gnu: unionfs-fuse/static: Remove store references from the executable.
* gnu/packages/linux.scm (unionfs-fuse/static)[arguments]: Add #:phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 02a0ae36b5..ecb820092a 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1092,7 +1092,16 @@ UnionFS-FUSE additionally supports copy-on-write.")
libs " dl)"))))))
(arguments
'(#:tests? #f
- #:configure-flags '("-DCMAKE_EXE_LINKER_FLAGS=-static")))
+ #:configure-flags '("-DCMAKE_EXE_LINKER_FLAGS=-static")
+ #:phases (alist-cons-after
+ 'install 'post-install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (exe (string-append out "/bin/unionfs")))
+ ;; By default, 'unionfs' keeps references to
+ ;; $glibc/share/locale and similar stuff. Remove them.
+ (remove-store-references exe)))
+ %standard-phases)))
(inputs `(("fuse" ,fuse-static)))))
(define-public sshfs-fuse