summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-02-20 12:19:38 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-02-20 14:25:38 +0100
commitf18f8b73835f0f24d245d29acb3f0e034170c502 (patch)
treecd0741041f668b39a07f902fdd19a9d154d383d8 /gnu
parent6754032f0c908f09cb1fc9577133b712651aec69 (diff)
downloadguix-patches-f18f8b73835f0f24d245d29acb3f0e034170c502.tar
guix-patches-f18f8b73835f0f24d245d29acb3f0e034170c502.tar.gz
gnu: python-scipy: install UTF-8 locale.
* gnu/packages/python.scm (python-scipy): Install en_US.UTF-8 locale in install-doc phase to avoid encoding error.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 7dc7435b20..cb25419881 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2357,7 +2357,11 @@ toolkits.")
(html (string-append doc "/html"))
(pyver ,(string-append "PYVER=")))
(with-directory-excursion "doc"
- ;; Without setting this variable we get an encoding error.
+ ;; Install and set UTF-8 locale to avoid an encoding error.
+ (setenv "LOCPATH" (getcwd))
+ (system* "localedef" "--no-archive"
+ "--prefix" (getcwd) "-i" "en_US"
+ "-f" "UTF-8" "./en_US.UTF-8")
(setenv "LANG" "en_US.UTF-8")
;; Fix generation of images for mathematical expressions.
(substitute* (find-files "source" "conf\\.py")