summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-02-18 16:08:33 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-02-20 14:26:48 +0100
commit865a69ddc82b13c6b5c4473f1d9cf798d5786514 (patch)
tree091b1a147c169a2fe1c5169de0f63b43cd023a65 /gnu
parentf18f8b73835f0f24d245d29acb3f0e034170c502 (diff)
downloadguix-patches-865a69ddc82b13c6b5c4473f1d9cf798d5786514.tar
guix-patches-865a69ddc82b13c6b5c4473f1d9cf798d5786514.tar.gz
gnu: Add arpack-ng.
* gnu/packages/maths.scm (arpack-ng): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index c3cf30c7a7..8c4eb3bd2f 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2014 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2014 Mathieu Lirzin <mathieu.lirzin@openmailbox.org>
+;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -212,6 +213,30 @@ can be imported from spreadsheets, text files and database sources and it can
be output in text, PostScript, PDF or HTML.")
(license license:gpl3+)))
+(define-public arpack-ng
+ (package
+ (name "arpack-ng")
+ (version "3.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/opencollab/arpack-ng/archive/"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1fwch6vipms1ispzg2djvbzv5wag36f1dmmr3xs3mbp6imfyhvff"))))
+ (build-system gnu-build-system)
+ (home-page "https://github.com/opencollab/arpack-ng")
+ (inputs
+ `(("lapack" ,lapack)
+ ("fortran" ,gfortran-4.8)))
+ (synopsis "Fortran subroutines for solving eigenvalue problems")
+ (description
+ "ARPACK-NG is a collection of Fortran77 subroutines designed to solve
+large scale eigenvalue problems.")
+ (license (license:bsd-style "file://COPYING"
+ "See COPYING in the distribution."))))
+
(define-public lapack
(package
(name "lapack")