summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorDavid Thompson <davet@gnu.org>2015-05-27 21:34:47 -0400
committerDavid Thompson <davet@gnu.org>2015-05-29 20:05:57 -0400
commite69620098ba337d13c810d188c15b9b2e576bd8b (patch)
tree5b5aacd79f7130dba15aed25b39474cc2c933165 /gnu
parenteb0c2dd62f8066354f85c62f4f958dd8d2a7f6ef (diff)
downloadguix-patches-e69620098ba337d13c810d188c15b9b2e576bd8b.tar
guix-patches-e69620098ba337d13c810d188c15b9b2e576bd8b.tar.gz
gnu: Add ruby-rspec-expectations.
* gnu/packages/ruby.scm (ruby-diff-lcs-for-rspec, ruby-rspec-expectations): New variables.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index ba417a4660..a77b684578 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -215,3 +215,52 @@ an extensible architecture with a swappable backend.")
groups.")
(home-page "https://github.com/rspec/rspec-core")
(license license:expat)))
+
+(define ruby-diff-lcs-for-rspec
+ (package
+ (name "ruby-diff-lcs")
+ (version "1.2.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/halostatue/diff-lcs/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0kmfz2qdwbfjf97rx27hh9fm39mv3z9avjmvsajqnb5wxj2l5l4s"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f)) ; avoid dependency cycles
+ (synopsis "Compute the difference between two Enumerable sequences")
+ (description "Diff::LCS computes the difference between two Enumerable
+sequences using the McIlroy-Hunt longest common subsequence (LCS) algorithm.
+It includes utilities to create a simple HTML diff output format and a
+standard diff-like tool.")
+ (home-page "https://github.com/halostatue/diff-lcs")
+ (license license:expat)))
+
+(define-public ruby-rspec-expectations
+ (package
+ (name "ruby-rspec-expectations")
+ (version "3.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/rspec/rspec-expectations/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0h0rpprbh6h59gmksiyi1b8w6cvcai4wdbkikajwx3w1asxi6f7x"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:tests? #f)) ; avoid dependency cycles
+ (propagated-inputs
+ `(("ruby-rspec-support" ,ruby-rspec-support)
+ ("ruby-diff-lcs" ,ruby-diff-lcs-for-rspec)))
+ (synopsis "RSpec expecations library")
+ (description "Rspec-expectations provides a simple API to express expected
+outcomes of a code example.")
+ (home-page "https://github.com/rspec/rspec-expectations")
+ (license license:expat)))