summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-05-26 17:44:18 +0800
committer宋文武 <iyzsong@gmail.com>2015-05-26 17:44:18 +0800
commit6344feb318d3ee9fda0b5dc0182b5e31878afa0c (patch)
treedbeddd58b2d56906be764535bd99b54d1176627c /gnu
parent6dc67c02f7083ad739935139aabaa94a442c2706 (diff)
parent30f9cbb072755cf76fe942038420cfda2af29f3e (diff)
downloadguix-patches-6344feb318d3ee9fda0b5dc0182b5e31878afa0c.tar
guix-patches-6344feb318d3ee9fda0b5dc0182b5e31878afa0c.tar.gz
Merge branch 'gtk-rebuild'
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm18
-rw-r--r--gnu/packages/gtk.scm38
2 files changed, 43 insertions, 13 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index cfbb8f3bba..35af94f4fc 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -506,6 +506,20 @@ update-desktop-database: updates the database containing a cache of MIME types
"Icons for the GNOME desktop.")
(license license:lgpl3))) ; or Creative Commons BY-SA 3.0
+;; gnome-icon-theme was renamed to adwaita-icon-theme after version 3.12.0.
+(define-public adwaita-icon-theme
+ (package (inherit gnome-icon-theme)
+ (name "adwaita-icon-theme")
+ (version "3.16.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnome/sources/" name "/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1hmlw7kvhr7c2asc5y77adpymi9ka17gaf76zz835nwwffnn4rlw"))))))
+
(define-public shared-mime-info
(package
(name "shared-mime-info")
@@ -746,7 +760,7 @@ dealing with different structured file formats.")
(define-public librsvg
(package
(name "librsvg")
- (version "2.40.6")
+ (version "2.40.9")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -754,7 +768,7 @@ dealing with different structured file formats.")
name "-" version ".tar.xz"))
(sha256
(base32
- "01jgb11779080b80k2ncrhdphgillqrrnszal6vh8yv787r4kwwa"))))
+ "0fplymmqqr28y24vcnb01szn62pfbqhk8p1ngns54x9m6mflr5hk"))))
(build-system gnu-build-system)
(arguments
`(#:phases
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 049c63162e..f518992498 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -138,24 +138,28 @@ affine transformation (scale, rotation, shear, etc.)")
(define-public harfbuzz
(package
(name "harfbuzz")
- (version "0.9.22")
+ (version "0.9.40")
(source (origin
(method url-fetch)
(uri (string-append "http://www.freedesktop.org/software/harfbuzz/release/harfbuzz-"
version ".tar.bz2"))
(sha256
(base32
- "1nkimwadri6v2kzrmz8y0crmy59gw0kg4i4f6cc786bngs0815lq"))))
+ "07rjp05axas96fp23lpf8l2yyfdj9yib4m0qjv592vdyhcsxaw8p"))))
(build-system gnu-build-system)
(inputs
`(("cairo" ,cairo)
("graphite2" ,graphite2)
("icu4c" ,icu4c)))
+ (propagated-inputs
+ `(("glib" ,glib))) ; required by harfbuzz-gobject.pc
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("python" ,python-wrapper)))
+ `(("gobject-introspection" ,gobject-introspection)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-2))) ; incompatible with Python 3 (print syntax)
(arguments
- `(#:configure-flags `("--with-graphite2=yes")))
+ `(#:configure-flags `("--with-graphite2"
+ "--with-gobject")))
(synopsis "OpenType text shaping engine")
(description
"HarfBuzz is an OpenType text shaping engine.")
@@ -426,7 +430,7 @@ is part of the GNOME accessibility project.")
(define-public gtk+-2
(package
(name "gtk+")
- (version "2.24.27")
+ (version "2.24.28")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -434,7 +438,7 @@ is part of the GNOME accessibility project.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1x14rnjvqslpa1q19fp1qalz5sxds72amsgjk8m7769rwk511jr0"))))
+ "0mj6xn40py9r9lvzg633fal81xfwfm89d9mvz7jk4lmwk0g49imj"))))
(build-system gnu-build-system)
(outputs '("out" "doc"))
(propagated-inputs
@@ -482,7 +486,7 @@ application suites.")
(define-public gtk+
(package (inherit gtk+-2)
(name "gtk+")
- (version "3.16.2")
+ (version "3.16.3")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
@@ -490,7 +494,7 @@ application suites.")
name "-" version ".tar.xz"))
(sha256
(base32
- "1yhwg2l72l3khfkprydcjlpxjrg11ccqfc80sjl56llz3jk66fd0"))))
+ "195ykv53sl2gsc847wcnd79zilm1yzcc2cfjxnrakhh2dd5gshr9"))))
(propagated-inputs
`(("at-spi2-atk" ,at-spi2-atk)
("atk" ,atk)
@@ -501,7 +505,8 @@ application suites.")
("libxdamage" ,libxdamage)
("pango" ,pango)))
(inputs
- `(("libxml2" ,libxml2)
+ `(("librsvg" ,librsvg) ;for gtk-encode-symbolic-svg
+ ("libxml2" ,libxml2)
("cups" ,cups))) ;for printing support
(native-inputs
`(("perl" ,perl)
@@ -533,7 +538,18 @@ application suites.")
"demos/gtk-demo/Makefile.in")
(("gtk-update-icon-cache") "$(bindir)/gtk-update-icon-cache"))
#t)
- %standard-phases)))))
+ (alist-cons-after
+ 'install 'wrap-gtk-encode-symbolic-svg
+ ;; By using GdkPixbuf, gtk-encode-symbolic-svg needs to know
+ ;; librsvg's loaders.cache to handle SVG files.
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (prog (string-append out "/bin/gtk-encode-symbolic-svg"))
+ (librsvg (assoc-ref inputs "librsvg"))
+ (loaders.cache (find-files librsvg "^loaders\\.cache$")))
+ (wrap-program prog
+ `("GDK_PIXBUF_MODULE_FILE" = ,loaders.cache))))
+ %standard-phases))))))
;;;
;;; Guile bindings.