summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorArne Babenhauserheide <arne.babenhauserheide@kit.edu>2013-10-11 22:16:50 +0200
committerLudovic Courtès <ludo@gnu.org>2013-10-11 22:18:47 +0200
commit5151c2e1f472bb27fdf5f68256d0ccc7707316cd (patch)
treeccf57711cfbc00e3ded09cb02f6d1fa5c3bc7633 /gnu
parent1a75f8d9391cc61eebccbecd9c2996022d561051 (diff)
downloadguix-patches-5151c2e1f472bb27fdf5f68256d0ccc7707316cd.tar
guix-patches-5151c2e1f472bb27fdf5f68256d0ccc7707316cd.tar.gz
gnu: Add Mercurial.
* gnu/packages/version-control.scm (mercurial): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/version-control.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 30660e830f..c23e742e7d 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -180,6 +180,33 @@ everything from small to very large projects with speed and efficiency.")
(license gpl2)
(home-page "http://git-scm.com/")))
+(define-public mercurial
+ (package
+ (name "mercurial")
+ (version "2.7.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://mercurial.selenic.com/release/mercurial-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "121m8f7vmipmdg00cnzdz2rjkgydh28mwfirqkrbs5fv089vywl4"))))
+ (build-system python-build-system)
+ (arguments
+ `(;; Restrict to Python 2, as Python 3 would require
+ ;; the argument --c2to3.
+ #:python ,python-2
+ ;; FIXME: Disabled tests because they require the nose unit
+ ;; testing framework: https://nose.readthedocs.org/en/latest/ .
+ #:tests? #f))
+ (home-page "http://mercurial.selenic.com")
+ (synopsis "Decentralized version control system")
+ (description
+ "Mercurial is a free, distributed source control management tool.
+It efficiently handles projects of any size
+and offers an easy and intuitive interface.")
+ (license gpl2+)))
+
(define-public subversion
(package
(name "subversion")