summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-10-10 20:04:53 +0200
committerAndreas Enge <andreas@enge.fr>2013-10-10 20:04:53 +0200
commit1ea44d11285fb5b138fab73310001ec9646ea4d5 (patch)
tree8a38138b6f5fe3ce5e822c458f203e7c3530f082 /gnu
parent39fa8f6c73d1fa8b6ea6260ffb0aee43d2c51dcd (diff)
downloadguix-patches-1ea44d11285fb5b138fab73310001ec9646ea4d5.tar
guix-patches-1ea44d11285fb5b138fab73310001ec9646ea4d5.tar.gz
gnu: qt: Do not use special SSE etc. instructions.
* gnu/packages/qt.scm (qt): Add configure flags to disable machine specific instructions.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/qt.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 8e3f812e53..230d1157fa 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -120,7 +120,18 @@ X11 (yet).")
"-verbose"
"-prefix" out
"-opensource"
- "-confirm-license"))))
+ "-confirm-license"
+ ;; drop all special machine instructions
+ "-no-sse2"
+ "-no-sse3"
+ "-no-ssse3"
+ "-no-sse4.1"
+ "-no-sse4.2"
+ "-no-avx"
+ "-no-avx2"
+ "-no-neon"
+ "-no-mips_dsp"
+ "-no-mips_dspr2"))))
%standard-phases)))
(home-page "http://qt-project.org/")
(synopsis "Cross-platform GUI library")