summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-10-31 23:29:25 +0100
committerLudovic Courtès <ludo@gnu.org>2013-10-31 23:38:58 +0100
commit215b643150c741f8d231daec510046b4f60c110a (patch)
treeb65b2b81bd40919df7271a2853c996a713a69723 /gnu
parentdce172273928f2ee6ac494725142ea5cd505002b (diff)
downloadguix-patches-215b643150c741f8d231daec510046b4f60c110a.tar
guix-patches-215b643150c741f8d231daec510046b4f60c110a.tar.gz
gnu: Add bridge-utils.
* gnu/packages/linux.scm (bridge-utils): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 1402f05974..cd1c921626 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -35,6 +35,7 @@
#:use-module (gnu packages pulseaudio)
#:use-module (gnu packages attr)
#:use-module (gnu packages xml)
+ #:use-module (gnu packages autotools)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system gnu))
@@ -719,3 +720,38 @@ Linux-based operating systems.")
;; License is BSD-3 or GPLv2, at the user's choice.
(license gpl2)))
+
+(define-public bridge-utils
+ (package
+ (name "bridge-utils")
+ (version "1.5")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/bridge/bridge-utils-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "12367cwqmi0yqphi6j8rkx97q8hw52yq2fx4k0xfclkcizxybya2"))))
+ (build-system gnu-build-system)
+
+ ;; The tarball lacks all the generated files.
+ (native-inputs `(("autoconf" ,autoconf)
+ ("automake" ,automake)))
+ (arguments
+ '(#:phases (alist-cons-before
+ 'configure 'bootstrap
+ (lambda _
+ (zero? (system* "autoreconf" "-vf")))
+ %standard-phases)
+ #:tests? #f)) ; no 'check' target
+
+ (home-page
+ "http://www.linuxfoundation.org/collaborate/workgroups/networking/bridge")
+ (synopsis "Manipulate Ethernet bridges")
+ (description
+ "Utilities for Linux's Ethernet bridging facilities. A bridge is a way
+to connect two Ethernet segments together in a protocol independent way.
+Packets are forwarded based on Ethernet address, rather than IP address (like
+a router). Since forwarding is done at Layer 2, all protocols can go
+transparently through a bridge.")
+ (license gpl2+)))