summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-31 21:36:47 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-31 23:11:05 +0200
commit73995969b133e50c04ad8f1e8a1428aef0eadb43 (patch)
tree64ded2ddc6369b677c54557bbd7860e5c6b24881 /gnu
parent1734853e92d1df9d1cb3c3bd747db6ed3feeab37 (diff)
downloadguix-patches-73995969b133e50c04ad8f1e8a1428aef0eadb43.tar
guix-patches-73995969b133e50c04ad8f1e8a1428aef0eadb43.tar.gz
gnu: Remove python-pytest-mock-3.
* gnu/packages/check.scm (python-pytest-mock-3): Remove variable. * gnu/packages/python-xyz.scm (python-anyio)[native-inputs]: Replace python-pytest-mock-3 with python-pytest-mock.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/check.scm27
-rw-r--r--gnu/packages/python-xyz.scm2
2 files changed, 1 insertions, 28 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 4e1b8e802c..b49f9de157 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1307,33 +1307,6 @@ same arguments.")
`(("python2-mock" ,python2-mock)
,@(package-propagated-inputs base))))))
-(define-public python-pytest-mock-3
- (package
- (inherit python-pytest-mock)
- (version "3.6.1")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "pytest-mock" version))
- (sha256
- (base32
- "0qhfmd05z3g88bnwq6644jl6p5wy01i4yy7h8883z9jjih2pl8a0"))))
- (properties '())
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
- (when tests?
- ;; Make the installed plugin discoverable by Pytest.
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-vv"
- ;; TODO: these fail for unclear reasons
- "-k"
- (string-append
- "not test_standalone_mock"
- " and not test_detailed_introspection_async"))))))))))
-
(define-public python-pytest-xdist
(package
(name "python-pytest-xdist")
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 577353e65d..07c9127c19 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -23107,7 +23107,7 @@ standard error channel (stderr) in your program.")
("python-iniconfig" ,python-iniconfig)
("python-mock" ,python-mock)
("python-pytest" ,python-pytest-6)
- ("python-pytest-mock" ,python-pytest-mock-3)
+ ("python-pytest-mock" ,python-pytest-mock)
("python-pytest-trio" ,python-pytest-trio)
("python-setuptools-scm" ,python-setuptools-scm)
("python-trustme" ,python-trustme)