summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorng0 <ng0@no-reply.pragmatique.xyz>2017-05-25 12:48:16 +0000
committerMarius Bakke <mbakke@fastmail.com>2017-05-25 20:05:11 +0200
commitfd7000fe33d3c4188c241cab97e2b891dd4e1268 (patch)
treef8545e8572833fecc0191d90d930f74d6f813735 /gnu
parent2af3743bc26f2ff81187bc3c4077eb54f762e070 (diff)
downloadguix-patches-fd7000fe33d3c4188c241cab97e2b891dd4e1268.tar
guix-patches-fd7000fe33d3c4188c241cab97e2b891dd4e1268.tar.gz
gnu: kbd: Add 'native-search-paths'.
* gnu/packages/linux.scm (kbd)[native-search-paths]: Add it. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index c9d8dadeca..d6ffa95ca5 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -18,7 +18,7 @@
;;; Copyright © 2016, 2017 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2016 Rene Saavedra <rennes@openmailbox.org>
;;; Copyright © 2016 Carlos Sánchez de La Lama <csanchezdll@gmail.com>
-;;; Copyright © 2016 ng0 <ng0@libertad.pw>
+;;; Copyright © 2016, 2017 ng0 <ng0@no-reply.pragmatique.xyz>
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2017 José Miguel Sánchez García <jmi2k@openmailbox.com>
;;; Copyright © 2017 Gábor Boskovits <boskovits@gmail.com>
@@ -1689,6 +1689,10 @@ system.")
("gzip" ,gzip)
("bzip2" ,bzip2)
("pam" ,linux-pam)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "LOADKEYS_KEYMAP_PATH")
+ (files (list "share/keymaps")))))
(native-inputs `(("pkg-config" ,pkg-config)))
(home-page "http://kbd-project.org/")
(synopsis "Linux keyboard utilities and keyboard maps")