summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorphodina <phodina@protonmail.com>2021-09-04 07:38:57 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-09-22 16:57:50 +0200
commitc9466cf2c9ac65c2b83210962f061768343b5efe (patch)
tree47429a7e5f203f0d4843555efa891ab946d3eff2 /gnu
parent8fc86858e50a7d0bfd2e59efcdebade3b06cf2bb (diff)
downloadguix-patches-c9466cf2c9ac65c2b83210962f061768343b5efe.tar
guix-patches-c9466cf2c9ac65c2b83210962f061768343b5efe.tar.gz
gnu: Add rust-path-slash-0.1.
* gnu/packages/crates-io.scm (rust-path-slash-0.1): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 2cd3754f32..5a3f4fd241 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -45369,6 +45369,27 @@ data type.")
(base32 "08xw8w61zdfn1094qkq1d554vh5wmm9bqdys8gqqxc4sv2pgrd0p"))))
(arguments `(#:skip-build? #t))))
+(define-public rust-path-slash-0.1
+ (package
+ (name "rust-path-slash")
+ (version "0.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "path-slash" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "06dnnmd3fvmr9ngwgj0xrfj9s8h09m9dgf3zlqsbalzk9wybpb1w"))))
+ (build-system cargo-build-system)
+ (arguments `(#:skip-build? #t))
+ (home-page "https://github.com/rhysd/path-slash")
+ (synopsis "Conversion to/from a file path from/to slash path")
+ (description
+ "Path-slash is a tiny library to convert a file path (e.g., @samp{foo/bar},
+@samp{foo\bar} or @samp{C:\foo\bar}) from or to slash path (e.g.,
+@samp{foo/bar}, @samp{C:/foo/bar}).")
+ (license license:expat)))
+
;; TODO: Unbundle sleef.
(define-public rust-sleef-sys-0.1
(package