summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-11-26 13:05:31 -0500
committerLeo Famulari <leo@famulari.name>2021-11-26 16:48:33 -0500
commitb67315c3c4b214cb2cdccacf4d5af79e647f56b7 (patch)
tree9b95df28f636802ddf3a5459b09cd1a316eb9407 /gnu
parent74364d9506e97776f02ff7d6159b533442d52ecb (diff)
downloadguix-patches-b67315c3c4b214cb2cdccacf4d5af79e647f56b7.tar
guix-patches-b67315c3c4b214cb2cdccacf4d5af79e647f56b7.tar.gz
gnu: linux-libre 5.10: Update to 5.10.82.
* gnu/packages/linux.scm (linux-libre-5.10-version): Update to 5.10.82. (linux-libre-5.10-pristine-source): Update hash. (linux-libre-5.10-source): Remove obsolete patch 'linux-libre-arm64-generic-pinebook-lcd.patch'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ece3c588e8..8baba7a743 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -366,7 +366,7 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
;; The "longterm" kernels — the older releases with long-term upstream support.
;; Here are the support timelines:
;; <https://www.kernel.org/category/releases.html>
-(define-public linux-libre-5.10-version "5.10.81")
+(define-public linux-libre-5.10-version "5.10.82")
(define-public linux-libre-5.10-gnu-revision "gnu1")
(define deblob-scripts-5.10
(linux-libre-deblob-scripts
@@ -376,7 +376,7 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(base32 "024rz0bp3n3r5nkwbib7byx10d72c2fh5cw9iv00diyzgnp819g7")))
(define-public linux-libre-5.10-pristine-source
(let ((version linux-libre-5.10-version)
- (hash (base32 "1nssv94zivx08vrxxflq4dxk5fxl3azsqlnzvw58qnf469hniqd2")))
+ (hash (base32 "0l73ikzndkkvy0r28rvd59l17shfqwk1mjdka3jlmy02xmz7qvyn")))
(make-linux-libre-source version
(%upstream-linux-source version hash)
deblob-scripts-5.10)))
@@ -495,10 +495,7 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(define-public linux-libre-5.10-source
(source-with-patches linux-libre-5.10-pristine-source
(list %boot-logo-patch
- %linux-libre-arm-export-__sync_icache_dcache-patch
- ;; Pinebook Pro patch to fix LCD display
- (search-patch
- "linux-libre-arm64-generic-pinebook-lcd.patch"))))
+ %linux-libre-arm-export-__sync_icache_dcache-patch)))
(define-public linux-libre-5.4-source
(source-with-patches linux-libre-5.4-pristine-source