summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:35 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:31 +0200
commit26ed7052120a868b8c89ed5fc27b2c35ad44caa4 (patch)
tree6afe6a049ef43cb82b64523f1f735b4fcf2ceca6 /gnu
parent97a07e7467801e82c035098d610000057f569a4c (diff)
downloadguix-patches-26ed7052120a868b8c89ed5fc27b2c35ad44caa4.tar
guix-patches-26ed7052120a868b8c89ed5fc27b2c35ad44caa4.tar.gz
gnu: Add trytond-purchase-requisition.
* gnu/packages/tryton.scm (trytond-purchase-requisition): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tryton.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 0e197bac2f..fbdfb27fcc 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2873,6 +2873,37 @@ suppliers. Each request will collect quotation information from the
supplier.")
(license license:gpl3+)))
+(define-public trytond-purchase-requisition
+ (package
+ (name "trytond-purchase-requisition")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_purchase_requisition" version))
+ (sha256
+ (base32 "0hiz4q4cq7zz6xxl6bkk0vn71hc2wgasnhda5h41cmi69jphhzzk"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "purchase_requisition"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-company" ,trytond-company)
+ ("trytond-currency" ,trytond-currency)
+ ("trytond-party" ,trytond-party)
+ ("trytond-product" ,trytond-product)
+ ("trytond-purchase" ,trytond-purchase)
+ ("trytond-purchase-request" ,trytond-purchase-request)))
+ (home-page "https://docs.tryton.org/projects/modules-purchase-requisition")
+ (synopsis "Tryton module to enter requests for product
+supply (requisition)")
+ (description "The @emph{Purchase Requisition} Tryton module allows users
+to create their requests for product supply (purchase requisitions). Those
+requisitions will be approved or rejected by the approval group, whoich
+typically is the purchasing department. On approval, purchase requests will
+be created.")
+ (license license:gpl3+)))
+
(define-public trytond-stock
(package
(name "trytond-stock")