summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:33 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:30 +0200
commit218c16095b7c81d8eb06b506cd56025f5af27856 (patch)
tree8bdcab046db8c48ab2275c0d679fab213f2543c7 /gnu
parentd0ea8226cc30177c2d0b2a5ff00a822319d5da69 (diff)
downloadguix-patches-218c16095b7c81d8eb06b506cd56025f5af27856.tar
guix-patches-218c16095b7c81d8eb06b506cd56025f5af27856.tar.gz
gnu: Add trytond-project-revenue.
* gnu/packages/tryton.scm (trytond-project-revenue): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tryton.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index d9b193f90b..60eada82bc 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2637,6 +2637,38 @@ methods on projects. The methods are:
on top of the Project module.")
(license license:gpl3+)))
+(define-public trytond-project-revenue
+ (package
+ (name "trytond-project-revenue")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_project_revenue" version))
+ (sha256
+ (base32 "0gji7kpq4l1smxvj6dqdpcyp2ml4ywfhagf6xm813y71mrlfvmka"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "project_revenue"))
+ (native-inputs
+ `(,@%standard-trytond-native-inputs
+ ("trytond-purchase" ,trytond-purchase)))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-company" ,trytond-company)
+ ("trytond-product" ,trytond-product)
+ ("trytond-project" ,trytond-project)
+ ("trytond-timesheet" ,trytond-timesheet)
+ ("trytond-timesheet-cost" ,trytond-timesheet-cost)))
+ (home-page "https://docs.tryton.org/projects/modules-project-revenue")
+ (synopsis "Tryton module to add revenue on project")
+ (description "The @emph{Project Revenue} Tryton module computes revenue
+and cost per task and project. The revenue uses the list price of the
+product. If the product's unit of measure is time based, the revenue is
+computed as the product of the price and the hours of effort otherwise the
+price is considered as fixed. The cost is computed by summing the cost of all
+the linked time sheets and the linked purchase lines.")
+ (license license:gpl3+)))
+
(define-public trytond-purchase
(package
(name "trytond-purchase")