summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorChris Marusich <cmmarusich@gmail.com>2016-04-02 13:29:05 -0700
committerAlex Kost <alezost@gmail.com>2016-04-15 11:32:37 +0300
commit4670f70a7ffbfed0427260537c99d92bc00ab80b (patch)
tree7d9b77e0b1373eb7f1440a177c733b4f5c962d59 /gnu
parente9687748e1d0c92de4cb4c1db5dbe90d30486a2f (diff)
downloadguix-patches-4670f70a7ffbfed0427260537c99d92bc00ab80b.tar
guix-patches-4670f70a7ffbfed0427260537c99d92bc00ab80b.tar.gz
gnu: Add emacs-rfcview.
* gnu/packages/emacs.scm (emacs-rfcview): New variable. Signed-off-by: Alex Kost <alezost@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 188824a48b..07530a9aeb 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -6,6 +6,7 @@
;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016 Nils Gillmann <niasterisk@grrlz.net>
+;;; Copyright © 2016 Chris Marusich <cmmarusich@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1506,3 +1507,30 @@ without modifier keys. It's similar to Vim's separation of commands and
insertion mode. When enabled all keys are implicitly prefixed with
@samp{C-} (among other helpful shortcuts).")
(license license:gpl3+))))
+
+(define-public emacs-rfcview
+ (package
+ (name "emacs-rfcview")
+ (version "0.13")
+ (home-page "http://www.loveshack.ukfsn.org/emacs")
+ (source (origin
+ (method uncompressed-file-fetch)
+ (uri "http://www.loveshack.ukfsn.org/emacs/rfcview.el")
+ (sha256
+ (base32
+ "0ympj5rxig383zl2jf0pzdsa80nnq0dpvjiriq0ivfi98fj7kxbz"))))
+ (build-system emacs-build-system)
+ (native-inputs
+ `(("emacs" ,emacs-no-x)))
+ (synopsis "Prettify Request for Comments (RFC) documents")
+ (description "The Internet Engineering Task Force (IETF) and the Internet
+Society (ISOC) publish various Internet-related protocols and specifications
+as \"Request for Comments\" (RFC) documents and Internet Standard (STD)
+documents. RFCs and STDs are published in a simple text form. This package
+provides an Emacs major mode, rfcview-mode, which makes it more pleasant to
+read these documents in Emacs. It prettifies the text and adds
+hyperlinks/menus for easier navigation. It also provides functions for
+browsing the index of RFC documents and fetching them from remote servers or
+local directories.")
+ (license license:gpl3+)))
+