summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2022-01-05 19:16:11 +0000
committerLeo Famulari <leo@famulari.name>2022-01-05 15:50:59 -0500
commit707acc4cfb5e965fe471cd77220c16e25f986a5c (patch)
treea34ed05d5241b1876fbd0ffd7ccfcbe3f1d287f7 /gnu
parent0fea9aec59f8f328c269d585d849a8f954e39aae (diff)
downloadguix-patches-707acc4cfb5e965fe471cd77220c16e25f986a5c.tar
guix-patches-707acc4cfb5e965fe471cd77220c16e25f986a5c.tar.gz
gnu: supertux: Update to 0.6.3.
* gnu/packages/games.scm (supertux): Update to 0.6.3. [inputs] Sort list and add glm. * gnu/packages/patches/supertux-unbundle-squirrel.patch: Adjust patch to apply with upstream changes. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm23
-rw-r--r--gnu/packages/patches/supertux-unbundle-squirrel.patch17
2 files changed, 22 insertions, 18 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index d884df588a..bfd566aac0 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -5442,7 +5442,7 @@ with the \"Stamp\" tool within Tux Paint.")
(define-public supertux
(package
(name "supertux")
- (version "0.6.2")
+ (version "0.6.3")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/SuperTux/supertux/"
@@ -5451,7 +5451,7 @@ with the \"Stamp\" tool within Tux Paint.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "167m3z4m8n76dvbv42m1fnvabpbpsxvr28zk9641916jl9pfba96"))
+ "1xkr3ka2sxp5s0spp84iv294i29s1vxqzazb6kmjc0n415h0x57p"))
(patches
(search-patches "supertux-unbundle-squirrel.patch"))))
(arguments
@@ -5471,18 +5471,19 @@ with the \"Stamp\" tool within Tux Paint.")
(string-append "${SQUIRREL_PREFIX}/include/squirrel"))))
#t)))))
(build-system cmake-build-system)
- (inputs (list sdl2
- sdl2-image
- sdl2-mixer
- openal
- mesa
+ (inputs (list boost
+ curl
+ freetype
glew
- libvorbis
+ glm
libogg
+ libvorbis
+ mesa
+ openal
physfs
- curl
- boost
- freetype
+ sdl2
+ sdl2-image
+ sdl2-mixer
squirrel))
(native-inputs
(list pkg-config))
diff --git a/gnu/packages/patches/supertux-unbundle-squirrel.patch b/gnu/packages/patches/supertux-unbundle-squirrel.patch
index 054183b75f..f504aacfdd 100644
--- a/gnu/packages/patches/supertux-unbundle-squirrel.patch
+++ b/gnu/packages/patches/supertux-unbundle-squirrel.patch
@@ -1,9 +1,8 @@
-diff -ur a/CMakeLists.txt b/CMakeLists.txt
---- a/CMakeLists.txt 2019-05-24 17:58:19.693090158 -0400
-+++ b/CMakeLists.txt 2019-05-24 17:57:43.349473252 -0400
-@@ -375,44 +375,15 @@
-
- include(ConfigureChecks)
+--- a/CMakeLists.txt 2022-01-05 18:51:17.828392874 +0100
++++ b/CMakeLists.txt 2022-01-05 18:54:50.826717830 +0100
+@@ -487,48 +487,15 @@
+ include_directories(${CMAKE_CURRENT_SOURCE_DIR}/src/ppc)
+ endif()
-
-## Also build external/squirrel
@@ -15,6 +14,9 @@ diff -ur a/CMakeLists.txt b/CMakeLists.txt
set(SQUIRREL_PREFIX ${CMAKE_BINARY_DIR}/squirrel/ex)
-ExternalProject_Add(squirrel
- SOURCE_DIR "${CMAKE_SOURCE_DIR}/external/squirrel/"
+- BUILD_BYPRODUCTS
+- "${SQUIRREL_PREFIX}/lib/${CMAKE_STATIC_LIBRARY_PREFIX}sqstdlib_static${CMAKE_STATIC_LIBRARY_SUFFIX}"
+- "${SQUIRREL_PREFIX}/lib/${CMAKE_STATIC_LIBRARY_PREFIX}squirrel_static${CMAKE_STATIC_LIBRARY_SUFFIX}"
- CMAKE_ARGS
- -DCMAKE_BUILD_TYPE=${CMAKE_BUILD_TYPE}
- -DCMAKE_C_COMPILER=${CMAKE_C_COMPILER}
@@ -22,7 +24,8 @@ diff -ur a/CMakeLists.txt b/CMakeLists.txt
- -DCMAKE_CXX_COMPILER=${CMAKE_CXX_COMPILER}
- -DCMAKE_CXX_FLAGS=${CMAKE_CXX_FLAGS}
- -DCMAKE_INSTALL_PREFIX=${SQUIRREL_PREFIX}
-- -DINSTALL_INC_DIR=include)
+- -DINSTALL_INC_DIR=include
+- -DCMAKE_POSITION_INDEPENDENT_CODE=ON)
-
-if(WIN32)
- add_library(squirrel_lib SHARED IMPORTED)