summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMorgan Smith <Morgan.J.Smith@outlook.com>2020-09-15 08:57:34 -0400
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-09-16 22:06:06 +0200
commit67b1ca4283533abebeea715d90f67f353748e1f2 (patch)
tree8d6db097e18b4f145bd77e38a42de9e87e00730c /gnu
parent891b045f3848596c8939e31e80185f31448cade1 (diff)
downloadguix-patches-67b1ca4283533abebeea715d90f67f353748e1f2.tar
guix-patches-67b1ca4283533abebeea715d90f67f353748e1f2.tar.gz
gnu: Add emacs-eshell-syntax-highlighting.
* gnu/packages/emacs-xyz.scm (emacs-eshell-syntax-highlighting): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 46af73456b..f27c6fa6eb 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -16924,6 +16924,27 @@ visiting the bookmark, a new @code{eshell} session will be opened in the
appropriate directory if no @code{eshell} session is active.")
(license license:gpl3+)))
+(define-public emacs-eshell-syntax-highlighting
+ (package
+ (name "emacs-eshell-syntax-highlighting")
+ (version "0.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/akreisher/eshell-syntax-highlighting")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0id27874wsb5y169030x8g1ldpa1mnskv1s2j3ygqiyh5fvpfash"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/akreisher/eshell-syntax-highlighting")
+ (synopsis "Add syntax highlighting to Eshell")
+ (description
+ "This package highlights user commands at the Eshell interactive prompt
+to provide feedback on the validity of commands and syntax.")
+ (license license:gpl3+)))
+
(define-public emacs-eshell-z
(package
(name "emacs-eshell-z")