summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-02-01 12:55:57 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-02-01 12:55:57 +0100
commita71019960603ef50335a6579bc94b6d607ae5798 (patch)
tree620dab7db1c7ce53be368eae7a2f02d285df3c3e /gnu
parent8a4644336d5063fd0bf43e90e3c0823c76e82e4e (diff)
downloadguix-patches-a71019960603ef50335a6579bc94b6d607ae5798.tar
guix-patches-a71019960603ef50335a6579bc94b6d607ae5798.tar.gz
gnu: Add ghc-iwlib.
* gnu/packages/haskell.scm (ghc-iwlib): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 21858e481c..0840ef42b2 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -42,6 +42,7 @@
#:use-module (gnu packages haskell-crypto)
#:use-module (gnu packages haskell-web)
#:use-module (gnu packages libffi)
+ #:use-module (gnu packages linux)
#:use-module (gnu packages lisp)
#:use-module (gnu packages lua)
#:use-module (gnu packages maths)
@@ -2068,6 +2069,28 @@ them on the longest match base. It is a kind of TRIE with one way branching
removed. Both IPv4 and IPv6 are supported.")
(license license:bsd-3)))
+(define-public ghc-iwlib
+ (package
+ (name "ghc-iwlib")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/iwlib/iwlib-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "0khmfwql4vwj55idsxmhjhrbqzfir3g9wm5lmpvnf77mm95cfpdz"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("wireless-tools" ,wireless-tools)))
+ (home-page "https://github.com/jaor/iwlib")
+ (synopsis "Haskell binding to the iw wireless networking library")
+ (description
+ "IWlib is a thin Haskell binding to the iw C library. It provides
+information about the current wireless network connections, and adapters on
+supported systems.")
+ (license license:bsd-3)))
+
(define-public ghc-regex-base
(package
(name "ghc-regex-base")