summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAniket Patil <aniket112.patil@gmail.com>2020-12-14 22:00:01 -0500
committerLeo Famulari <leo@famulari.name>2020-12-15 00:33:35 -0500
commit6b5c04034d121c393cb67f40da10d7bb718f1574 (patch)
tree9cb217e4aac2e46a4790a247722bdcee176790f2 /gnu
parent795f654b2a0593d2a09273fc7e39d7258c87d548 (diff)
downloadguix-patches-6b5c04034d121c393cb67f40da10d7bb718f1574.tar
guix-patches-6b5c04034d121c393cb67f40da10d7bb718f1574.tar.gz
gnu: Add r-locpol.
* gnu/packages/cran.scm (r-locpol): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 157ac82fd0..7ff0c933e0 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -25212,6 +25212,28 @@ estimation in measurement error models: The R package decon.
Journal of Statistical Software, 39(10), 1-24.")
(license license:gpl3+)))
+(define-public r-locpol
+ (package
+ (name "r-locpol")
+ (version "0.7-0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "locpol" version))
+ (sha256
+ (base32
+ "1p915n0l09kbwkly627074jslxl01yssp1rf0c7sygvsw6sgy5lm"))))
+ (properties `((upstream-name . "locpol")))
+ (build-system r-build-system)
+ (home-page
+ "https://cran.r-project.org/web/packages/locpol/")
+ (synopsis "Kernel Local Polynomial Regression")
+ (description
+ "Computes local polynomial estimators for the regression and
+also density. It comprises several different utilities to handle
+kernel estimators.")
+ (license license:gpl2+)))
+
(define-public r-aws-signature
(package
(name "r-aws-signature")