summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-07-09 02:35:23 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-07-15 03:33:34 +0200
commit4f4477a77e699142ea30162fd96519579ec9e12b (patch)
tree94954b54a57eee4ca97cb10c049c3457618b6b92 /gnu
parentd2b30db788f1743f9f8738cb1de977b77748567f (diff)
downloadguix-patches-4f4477a77e699142ea30162fd96519579ec9e12b.tar
guix-patches-4f4477a77e699142ea30162fd96519579ec9e12b.tar.gz
gnu: fuse: Do not refer to the native bash.
* gnu/packages/linux.scm (fuse)[inputs]: Add bash-minimal. [arguments]: Refer to it rather than to the native build bash. Do not return #t from phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 6f6115cb7e..a88edbea16 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -3084,7 +3084,9 @@ processes currently causing I/O.")
"1ddlq6kzxilccgbvxjfx80jx6kamgw4sv49phks2zhlcc1frvrnh"))
(patches (search-patches "fuse-overlapping-headers.patch"))))
(build-system gnu-build-system)
- (inputs `(("util-linux" ,util-linux)))
+ (inputs
+ `(("bash-minimal" ,bash-minimal)
+ ("util-linux" ,util-linux)))
(arguments
'(#:configure-flags (list (string-append "MOUNT_FUSE_PATH="
(assoc-ref %outputs "out")
@@ -3107,9 +3109,9 @@ processes currently causing I/O.")
(("/bin/(u?)mount" _ maybe-u)
(string-append (assoc-ref inputs "util-linux")
"/bin/" maybe-u "mount")))
- (substitute* '("util/mount.fuse.c")
- (("/bin/sh")
- (which "sh")))
+ (substitute* "util/mount.fuse.c"
+ (("/bin/sh" command)
+ (string-append (assoc-ref inputs "bash-minimal") command)))
;; This hack leads libfuse to search for 'fusermount' in
;; $PATH, where it may find a setuid-root binary, instead of
@@ -3117,8 +3119,7 @@ processes currently causing I/O.")
;; it's not setuid.
(substitute* "lib/Makefile"
(("-DFUSERMOUNT_DIR=[[:graph:]]+")
- "-DFUSERMOUNT_DIR=\\\"/var/empty\\\""))
- #t)))))
+ "-DFUSERMOUNT_DIR=\\\"/var/empty\\\"")))))))
(supported-systems (delete "i586-gnu" %supported-systems))
(home-page "https://github.com/libfuse/libfuse")
(synopsis "Support file systems implemented in user space")