summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2016-12-30 12:35:16 +0100
committerJulien Lepiller <julien@lepiller.eu>2017-01-17 23:21:42 +0100
commit800ab1fb16cb963ac9187acfa43a97dc10daa326 (patch)
tree591c6f34ebb311e781b0dca9dfdc0ff19d5b5ec4 /gnu
parent84290923d990575dba651ced7ccd7f827c05f245 (diff)
downloadguix-patches-800ab1fb16cb963ac9187acfa43a97dc10daa326.tar
guix-patches-800ab1fb16cb963ac9187acfa43a97dc10daa326.tar.gz
gnu: Add ocaml-jsonm.
* gnu/packages/ocaml.scm (ocaml-jsonm): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index efabd95a3f..0f90d9974d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1642,3 +1642,31 @@ position tracking and support newline normalization.
Functions are also provided to fold over the characters of UTF encoded OCaml
string values and to directly encode characters in OCaml Buffer.t values.")
(license license:isc)))
+
+(define-public ocaml-jsonm
+ (package
+ (name "ocaml-jsonm")
+ (version "1.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://erratique.ch/software/jsonm/releases/"
+ "jsonm-" version ".tbz"))
+ (sha256
+ (base32
+ "1v3ln6d965lplj28snjdqdqablpp1kx8bw2cfx0m6i157mqyln62"))))
+ (build-system ocaml-build-system)
+ (arguments `(#:tests? #f
+ #:build-flags (list "build")
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs `(("opam" ,opam)
+ ("topkg" ,ocaml-topkg)))
+ (propagated-inputs `(("uutf" ,ocaml-uutf)
+ ("cmdliner" ,ocaml-cmdliner)))
+ (home-page "http://erratique.ch/software/jsonm")
+ (synopsis "Non-blocking streaming JSON codec for OCaml")
+ (description "Jsonm is a non-blocking streaming codec to decode and encode
+the JSON data format. It can process JSON text without blocking on IO and
+without a complete in-memory representation of the data.")
+ (license license:isc)))