summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-01-16 12:18:12 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-01-17 21:46:49 +0100
commit71676a1f4c8d14239936c07113c5cd2a37770aa0 (patch)
treeb3526680f0880a590c43ddbfd9a58f906cca53ed /gnu
parentae2621743010ae498dbafa0a0e8b3b21f5826130 (diff)
downloadguix-patches-71676a1f4c8d14239936c07113c5cd2a37770aa0.tar
guix-patches-71676a1f4c8d14239936c07113c5cd2a37770aa0.tar.gz
gnu: Add r-mzr.
* gnu/packages/bioinformatics.scm (r-mzr): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 4a1bd01965..51660026eb 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8248,3 +8248,35 @@ as allowing spectra with different resolutions.")
"This package provides S4 generic functions needed by Bioconductor
proteomics packages.")
(license license:artistic2.0)))
+
+(define-public r-mzr
+ (package
+ (name "r-mzr")
+ (version "2.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "mzR" version))
+ (sha256
+ (base32
+ "0ipmhg6l3pf648rdx5g2ha7l5ppd3cja6afxhdw76x8ga3633x0r"))))
+ (properties `((upstream-name . "mzR")))
+ (build-system r-build-system)
+ (inputs
+ `(("netcdf" ,netcdf)))
+ (propagated-inputs
+ `(("r-biobase" ,r-biobase)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-protgenerics" ,r-protgenerics)
+ ("r-rcpp" ,r-rcpp)
+ ("r-zlibbioc" ,r-zlibbioc)))
+ (home-page "https://github.com/sneumann/mzR/")
+ (synopsis "Parser for mass spectrometry data files")
+ (description
+ "The mzR package provides a unified API to the common file formats and
+parsers available for mass spectrometry data. It comes with a wrapper for the
+ISB random access parser for mass spectrometry mzXML, mzData and mzML files.
+The package contains the original code written by the ISB, and a subset of the
+proteowizard library for mzML and mzIdentML. The netCDF reading code has
+previously been used in XCMS.")
+ (license license:artistic2.0)))