summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-07-05 13:50:36 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-07-17 11:04:45 +0200
commit655684468e28f841b432ac3f34751e29c6721953 (patch)
tree527d5a86aaf8efc9e4f78be5c9c25a5541a3dd52 /gnu
parentd0e4378266681c294754bb09ad8cfe810ffdb29e (diff)
downloadguix-patches-655684468e28f841b432ac3f34751e29c6721953.tar
guix-patches-655684468e28f841b432ac3f34751e29c6721953.tar.gz
gnu: Add emacs-fill-column-indicator.
* gnu/packages/emacs.scm (emacs-fill-column-indicator): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 371c3fae40..7a67b03f06 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1351,6 +1351,27 @@ keep pressing the key until it selects what you want. There's also
@code{er/contract-region} if you expand too far.")
(license license:gpl3+)))
+(define-public emacs-fill-column-indicator
+ (package
+ (name "emacs-fill-column-indicator")
+ (version "1.81")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/alpaker/Fill-Column-Indicator"
+ "/archive/v" version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1xwyqbjbbicmvhlb85vg4j5snwy1vd7rfk89ws4viws5ljkhhyg8"))))
+ (build-system emacs-build-system)
+ (home-page "https://www.emacswiki.org/emacs/FillColumnIndicator")
+ (synopsis "Graphically indicate the fill column")
+ (description
+ "Fill-column-indicator graphically indicates the location of the fill
+column by drawing a thin line down the length of the editing window.")
+ (license license:gpl3+)))
+
(define-public emacs-ob-ipython
(package
(name "emacs-ob-ipython")