summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-01-16 12:19:28 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-01-17 21:46:50 +0100
commit4aa7d592f18c690106b604029a884c0654795189 (patch)
treede27df707088212eb9cbf12a86d2bfc6e36f00bb /gnu
parent7c08afaf7bd86c543d46a1d3157a8a57bfed8af4 (diff)
downloadguix-patches-4aa7d592f18c690106b604029a884c0654795189.tar
guix-patches-4aa7d592f18c690106b604029a884c0654795189.tar.gz
gnu: Add r-mzid.
* gnu/packages/bioinformatics.scm (r-mzid): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 82a60dae05..4952bbe339 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8363,3 +8363,33 @@ analogous to \"normalized log-ratios\". However, in contrast to the latter,
their variance is independent of the mean, and they are usually more sensitive
and specific in detecting differential transcription.")
(license license:artistic2.0)))
+
+(define-public r-mzid
+ (package
+ (name "r-mzid")
+ (version "1.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "mzID" version))
+ (sha256
+ (base32
+ "1zn896cpfvqp1qmq5c4vcj933hb8rxwb6gkck1wqvr7393rpqy1q"))))
+ (properties `((upstream-name . "mzID")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-doparallel" ,r-doparallel)
+ ("r-foreach" ,r-foreach)
+ ("r-iterators" ,r-iterators)
+ ("r-plyr" ,r-plyr)
+ ("r-protgenerics" ,r-protgenerics)
+ ("r-rcpp" ,r-rcpp)
+ ("r-xml" ,r-xml)))
+ (home-page "http://bioconductor.org/packages/mzID")
+ (synopsis "Parser for mzIdentML files")
+ (description
+ "This package provides a parser for mzIdentML files implemented using the
+XML package. The parser tries to be general and able to handle all types of
+mzIdentML files with the drawback of having less pretty output than a vendor
+specific parser.")
+ (license license:gpl2+)))