summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-01-16 12:01:20 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-01-17 21:46:49 +0100
commit0e7d058e4482d8653778915d2ae4941f0ba20a67 (patch)
treea997f63d2cacdf886aa8f83b919d1c984245d78e /gnu
parent1f40e73cb52293d0ff429703136235398129887f (diff)
downloadguix-patches-0e7d058e4482d8653778915d2ae4941f0ba20a67.tar
guix-patches-0e7d058e4482d8653778915d2ae4941f0ba20a67.tar.gz
gnu: Add r-maldiquant.
* gnu/packages/bioinformatics.scm (r-maldiquant): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 743e8fdce9..74948ec556 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8202,3 +8202,29 @@ solution for binary trait. The package rareMETALS2 offers improved features
for analyzing gene-level association tests in meta-analyses for binary
trait.")
(license license:gpl3)))
+
+(define-public r-maldiquant
+ (package
+ (name "r-maldiquant")
+ (version "1.16")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "MALDIquant" version))
+ (sha256
+ (base32
+ "067xbmy10mpsvmv77g62chd7wwhdhcfn5hmp5fisbnz2h5rq0q60"))))
+ (properties `((upstream-name . "MALDIquant")))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/MALDIquant")
+ (synopsis "Quantitative analysis of mass spectrometry data")
+ (description
+ "This package provides a complete analysis pipeline for matrix-assisted
+laser desorption/ionization-time-of-flight (MALDI-TOF) and other
+two-dimensional mass spectrometry data. In addition to commonly used plotting
+and processing methods it includes distinctive features, namely baseline
+subtraction methods such as morphological filters (TopHat) or the
+statistics-sensitive non-linear iterative peak-clipping algorithm (SNIP), peak
+alignment using warping functions, handling of replicated measurements as well
+as allowing spectra with different resolutions.")
+ (license license:gpl3+)))