summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2015-10-07 18:57:24 +1000
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-10-15 12:21:50 +0200
commit07f61cb242713fee4c2025a6d106c395eae11ee6 (patch)
treefb3e3e5060b7daf19272ef3fd7a4585933bebf57 /gnu
parent5ac984b3d5444d51479e4d1a6190dc7b2b2beef4 (diff)
downloadguix-patches-07f61cb242713fee4c2025a6d106c395eae11ee6.tar
guix-patches-07f61cb242713fee4c2025a6d106c395eae11ee6.tar.gz
gnu: Add ruby-yard.
* gnu/packages/ruby.scm (ruby-yard): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 3101c01c09..701b7ee6ef 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1465,3 +1465,34 @@ and trust on your team.")
features such as filtering and fine grained logging.")
(home-page "https://github.com/pjotrp/bioruby-logger-plugin")
(license license:expat)))
+
+(define-public ruby-yard
+ (package
+ (name "ruby-yard")
+ (version "0.8.7.6")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "yard" version))
+ (sha256
+ (base32
+ "1dj6ibc0qqvmb5a5r5kk0vhr04mnrz9b26gnfrs5p8jgp620i89x"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:test-target "specs"
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'set-HOME
+ ;; $HOME needs to be set to somewhere writeable for tests to run
+ (lambda _ (setenv "HOME" "/tmp") #t)))))
+ (native-inputs
+ `(("ruby-rspec" ,ruby-rspec-2)
+ ("ruby-rack" ,ruby-rack)))
+ (synopsis "Documentation generation tool for Ruby")
+ (description
+ "YARD is a documentation generation tool for the Ruby programming
+language. It enables the user to generate consistent, usable documentation
+that can be exported to a number of formats very easily, and also supports
+extending for custom Ruby constructs such as custom class level definitions.")
+ (home-page "http://yardoc.org")
+ (license license:expat)))