summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-06-27 19:31:59 +0200
committerLudovic Courtès <ludo@gnu.org>2015-07-03 15:28:07 +0200
commitef2f51a445b23c8d9b8298e325bcc8cc7bb18ac0 (patch)
tree3ff0e27f8b79ad383fdaa74586853b2de6eb227d /gnu
parent6a52df505ad7d6d5026ea616dc9cc48b31d65011 (diff)
downloadguix-patches-ef2f51a445b23c8d9b8298e325bcc8cc7bb18ac0.tar
guix-patches-ef2f51a445b23c8d9b8298e325bcc8cc7bb18ac0.tar.gz
gnu: cups-filter: Install backends and filters under lib/cups.
This ensures that they are stripped during the 'strip' phase, thereby removing references to GCC and linux-libre-headers that would otherwise be found in debugging symbols. * gnu/packages/cups.scm (cups-filters)[source]: Change pkgbackenddir and pkgfilterdir to $(PREFIX)/lib/cups/{filter,backend}. (cups)[arguments]: Adjust accordingly.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cups.scm18
1 files changed, 11 insertions, 7 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 05b129d6a9..8d86cd6bad 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -54,10 +55,12 @@
"CUPS_DATADIR = $(PREFIX)/share/cups")
(("pkgcupsserverrootdir = \\$\\(CUPS_SERVERROOT\\)")
"pkgcupsserverrootdir = $(PREFIX)")
+ ;; Choose standard directories notably so that binaries are
+ ;; stripped.
(("pkgbackenddir = \\$\\(CUPS_SERVERBIN\\)/backend")
- "pkgbackenddir = $(PREFIX)/backend")
+ "pkgbackenddir = $(PREFIX)/lib/cups/backend")
(("pkgfilterdir = \\$\\(CUPS_SERVERBIN\\)/filter")
- "pkgfilterdir = $(PREFIX)/filter")))))
+ "pkgfilterdir = $(PREFIX)/lib/cups/filter")))))
(build-system gnu-build-system)
(arguments
`(#:make-flags (list (string-append "PREFIX=" %output))
@@ -196,7 +199,7 @@ device-specific programs to convert and print many types of files.")
(string-append
"for dir in "
(assoc-ref %outputs "out") "/lib/cups/filter "
- filters "/filter"))
+ filters "/lib/cups/filter"))
;; check for charsets in cups-filters output
(("/usr/share/cups/charsets")
@@ -264,15 +267,16 @@ device-specific programs to convert and print many types of files.")
(lambda (f)
(symlink f
(string-append out "/lib/cups/filter" (basename f))))
- (find-files (string-append cups-filters "/filter") ".*"))
+ (find-files (string-append cups-filters "/lib/cups/filter")))
;; backends
(for-each
(lambda (f)
(symlink (string-append cups-filters f)
- (string-append out "/lib/cups" f)))
- '("/backend/parallel"
- "/backend/serial"))
+ (string-append out "/lib/cups/backend/"
+ (basename f))))
+ '("/lib/cups/backend/parallel"
+ "/lib/cups/backend/serial"))
;; banners
(let ((banners "/share/cups/banners"))