summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-06-15 09:32:07 -0500
committerEric Bavier <bavier@member.fsf.org>2015-06-29 15:34:36 -0500
commite1ff597a647f81a80201db0d69d9048c08394bdc (patch)
treeb017cb72e562f6c5ebdd85596d2d9f04d6e58d3a /gnu
parentcf0ec6c46efbf303207235ede8a9828b79037fb3 (diff)
downloadguix-patches-e1ff597a647f81a80201db0d69d9048c08394bdc.tar
guix-patches-e1ff597a647f81a80201db0d69d9048c08394bdc.tar.gz
gnu: Add ScaLAPACK.
* gnu/packages/maths.scm (scalapack): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 05691b6a44..5954396508 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -305,6 +305,35 @@ problems in numerical linear algebra.")
(license (license:non-copyleft "file://LICENSE"
"See LICENSE in the distribution."))))
+(define-public scalapack
+ (package
+ (name "scalapack")
+ (version "2.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "http://www.netlib.org/scalapack/scalapack-"
+ version ".tgz"))
+ (sha256
+ (base32
+ "0p1r61ss1fq0bs8ynnx7xq4wwsdvs32ljvwjnx6yxr8gd6pawx0c"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("mpi" ,openmpi)
+ ("fortran" ,gfortran)
+ ("lapack" ,lapack))) ;for testing only
+ (arguments
+ `(#:configure-flags `("-DBUILD_SHARED_LIBS:BOOL=YES")))
+ (home-page "http://www.netlib.org/scalapack/")
+ (synopsis "Library for scalable numerical linear algebra")
+ (description
+ "ScaLAPACK is a Fortran 90 library of high-performance linear algebra
+routines on parallel distributed memory machines. ScaLAPACK solves dense and
+banded linear systems, least squares problems, eigenvalue problems, and
+singular value problems.")
+ (license (license:bsd-style "file://LICENSE"
+ "See LICENSE in the distribution."))))
+
(define-public gnuplot
(package
(name "gnuplot")