summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-06-17 12:22:19 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-07-02 11:16:46 +0200
commitc61fe02cc03178c2d6947de7e49c72f2abb73b7c (patch)
treed0fee3157ac2cd393261126153e555341c97e389 /gnu
parentf4f4ced8dccba6bc0b7c5d5e4c90cdb6488d1faf (diff)
downloadguix-patches-c61fe02cc03178c2d6947de7e49c72f2abb73b7c.tar
guix-patches-c61fe02cc03178c2d6947de7e49c72f2abb73b7c.tar.gz
gnu: Add WarpedLMM.
* gnu/packages/bioinformatics.scm (python2-warpedlmm): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index c7251c4c20..049e1c3308 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -1494,6 +1494,53 @@ interrupted by stop codons. OrfM finds and prints these ORFs.")
files and writing bioinformatics applications.")
(license license:bsd-3)))
+(define-public python2-warpedlmm
+ (package
+ (name "python2-warpedlmm")
+ (version "0.21")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/W/WarpedLMM/WarpedLMM-"
+ version ".zip"))
+ (sha256
+ (base32
+ "1agfz6zqa8nc6cw47yh0s3y14gkpa9wqazwcj7mwwj3ffnw39p3j"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2 ; requires Python 2.7
+ #:phases
+ (modify-phases %standard-phases
+ (add-after
+ 'install 'remove-bin-directory
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; The "bin" directory only contains wrappers for running
+ ;; the module tests. They are not needed after the
+ ;; "check" phase.
+ (delete-file-recursively
+ (string-append (assoc-ref outputs "out") "/bin"))
+ #t)))))
+ (propagated-inputs
+ `(("python-scipy" ,python2-scipy)
+ ("python-numpy" ,python2-numpy)
+ ("python-matplotlib" ,python2-matplotlib)
+ ("python-fastlmm" ,python2-fastlmm)
+ ("python-pandas" ,python2-pandas)
+ ("python-pysnptools" ,python2-pysnptools)))
+ (native-inputs
+ `(("python-setuptools" ,python2-setuptools)
+ ("python-mock" ,python2-mock)
+ ("python-nose" ,python2-nose)
+ ("unzip" ,unzip)))
+ (home-page "https://github.com/PMBio/warpedLMM")
+ (synopsis "Implementation of warped linear mixed models")
+ (description
+ "WarpedLMM is a Python implementation of the warped linear mixed model,
+which automatically learns an optimal warping function (or transformation) for
+the phenotype as it models the data.")
+ (license license:asl2.0)))
+
(define-public pbtranscript-tofu
(let ((commit "c7bbd5472"))
(package