summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-05-08 12:21:30 -0400
committerKei Kebreau <kei@openmailbox.org>2017-05-08 15:07:48 -0400
commit8bdc36d4bd5d38a5e595c9c51e61bad4caf291e0 (patch)
tree91123fa7c1565ca8c0c682c1b820050b40ba0d84 /gnu
parent65584b91c7029e93e6fd207f08c958206f1dcfc5 (diff)
downloadguix-patches-8bdc36d4bd5d38a5e595c9c51e61bad4caf291e0.tar
guix-patches-8bdc36d4bd5d38a5e595c9c51e61bad4caf291e0.tar.gz
gnu: Move links to web-browsers.scm.
* gnu/packages/links.scm: Remove file and move links... * gnu/packages/web-browsers.scm: ...here. * gnu/local.mk (GNU_SYSTEM_MODULES): Remove links.scm.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/links.scm81
-rw-r--r--gnu/packages/web-browsers.scm54
3 files changed, 54 insertions, 82 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index cc2d35e436..1922bb46ce 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -233,7 +233,6 @@ GNU_SYSTEM_MODULES = \
%D%/packages/libunwind.scm \
%D%/packages/libupnp.scm \
%D%/packages/lighting.scm \
- %D%/packages/links.scm \
%D%/packages/linux.scm \
%D%/packages/lirc.scm \
%D%/packages/lisp.scm \
diff --git a/gnu/packages/links.scm b/gnu/packages/links.scm
deleted file mode 100644
index 145ed761ee..0000000000
--- a/gnu/packages/links.scm
+++ /dev/null
@@ -1,81 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2014 John Darrington <jmd@gnu.org>
-;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages links)
- #:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix packages)
- #:use-module (gnu packages)
- #:use-module (gnu packages compression)
- #:use-module (gnu packages pkg-config)
- #:use-module (gnu packages image)
- #:use-module (gnu packages libevent)
- #:use-module (gnu packages tls)
- #:use-module (gnu packages xorg)
- #:use-module (guix download)
- #:use-module (guix build-system gnu))
-
-(define-public links
- (package
- (name "links")
- (version "2.14")
- (source (origin
- (method url-fetch)
- (uri (string-append "http://links.twibright.com/download/"
- name "-" version ".tar.bz2"))
- (sha256
- (base32 "1f24y83wa1vzzjq5kp857gjqdpnmf8pb29yw7fam0m8wxxw0c3gp"))))
- (build-system gnu-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- ;; The tarball uses a very old version of autconf. It doesn't
- ;; understand extra flags like `--enable-fast-install', so
- ;; we need to invoke it with just what it understands.
- (let ((out (assoc-ref outputs "out")))
- ;; 'configure' doesn't understand '--host'.
- ,@(if (%current-target-system)
- `((setenv "CHOST" ,(%current-target-system)))
- '())
- (setenv "CONFIG_SHELL" (which "bash"))
- (zero?
- (system* "./configure"
- (string-append "--prefix=" out)
- "--enable-graphics"))))))))
- (native-inputs `(("pkg-config" ,pkg-config)))
- (inputs `(("zlib" ,zlib)
- ("openssl" ,openssl)
- ("libjpeg" ,libjpeg)
- ("libtiff" ,libtiff)
- ("libevent" ,libevent)
- ("libpng" ,libpng)
- ("libxt" ,libxt)))
- (synopsis "Text and graphics mode web browser")
- (description "Links is a graphics and text mode web browser, with many
-features including, tables, builtin image display, bookmarks, SSL and more.")
- (home-page "http://links.twibright.com")
- ;; The distribution contains a copy of GPLv2
- ;; However, the copyright notices simply say:
- ;; "This file is a part of the Links program, released under GPL."
- ;; Therefore, under the provisions of Section 9, we can choose
- ;; any version ever published by the FSF.
- ;; One file (https.c) contains an exception permitting
- ;; linking of the program with openssl.
- (license license:gpl1+)))
diff --git a/gnu/packages/web-browsers.scm b/gnu/packages/web-browsers.scm
index 07b61dd25e..4cbd5fbe06 100644
--- a/gnu/packages/web-browsers.scm
+++ b/gnu/packages/web-browsers.scm
@@ -1,4 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 John Darrington <jmd@gnu.org>
+;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Kei Kebreau <kei@openmailbox.org>
;;; Copyright © 2017 Eric Bavier <bavier@member.fsf.org>
;;;
@@ -25,6 +27,7 @@
#:use-module (gnu packages documentation)
#:use-module (gnu packages fltk)
#:use-module (gnu packages fontutils)
+ #:use-module (gnu packages libevent)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
@@ -67,6 +70,57 @@ older or slower computers and embedded systems.")
(home-page "http://www.dillo.org")
(license license:gpl3+)))
+(define-public links
+ (package
+ (name "links")
+ (version "2.14")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://links.twibright.com/download/"
+ name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "1f24y83wa1vzzjq5kp857gjqdpnmf8pb29yw7fam0m8wxxw0c3gp"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; The tarball uses a very old version of autconf. It doesn't
+ ;; understand extra flags like `--enable-fast-install', so
+ ;; we need to invoke it with just what it understands.
+ (let ((out (assoc-ref outputs "out")))
+ ;; 'configure' doesn't understand '--host'.
+ ,@(if (%current-target-system)
+ `((setenv "CHOST" ,(%current-target-system)))
+ '())
+ (setenv "CONFIG_SHELL" (which "bash"))
+ (zero?
+ (system* "./configure"
+ (string-append "--prefix=" out)
+ "--enable-graphics"))))))))
+ (native-inputs `(("pkg-config" ,pkg-config)))
+ (inputs `(("zlib" ,zlib)
+ ("openssl" ,openssl)
+ ("libjpeg" ,libjpeg)
+ ("libtiff" ,libtiff)
+ ("libevent" ,libevent)
+ ("libpng" ,libpng)
+ ("libxt" ,libxt)))
+ (synopsis "Text and graphics mode web browser")
+ (description "Links is a graphics and text mode web browser, with many
+features including, tables, builtin image display, bookmarks, SSL and more.")
+ (home-page "http://links.twibright.com")
+ ;; The distribution contains a copy of GPLv2
+ ;; However, the copyright notices simply say:
+ ;; "This file is a part of the Links program, released under GPL."
+ ;; Therefore, under the provisions of Section 9, we can choose
+ ;; any version ever published by the FSF.
+ ;; One file (https.c) contains an exception permitting
+ ;; linking of the program with openssl.
+ (license license:gpl1+)))
+
(define-public qutebrowser
(package
(name "qutebrowser")