summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-11-06 18:11:21 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2018-11-12 10:30:10 +0100
commit46a4ae2212d72d38dc55188e35a7441964694f91 (patch)
treeb93bdbea27297b69215ca0701739ad43b123519e /gnu
parent66fa8f0f77ac26766e5547ffdaa67cf6c261bd8e (diff)
downloadguix-patches-46a4ae2212d72d38dc55188e35a7441964694f91.tar
guix-patches-46a4ae2212d72d38dc55188e35a7441964694f91.tar.gz
gnu: go-github-com-wtolson-go-taglib: Fix tests and build for go-1.11.
* gnu/packages/golang.scm (go-github-com-wtolson-go-taglib)[arguments]: Fix tests for go-1.11. [native-inputs]: Remove pkg-config and taglib. [propagated-inputs]: Add pkg-config and taglib.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/golang.scm17
1 files changed, 15 insertions, 2 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 5b84ced804..2fd8bf487c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2419,11 +2419,24 @@ and lookup requests. Browse requests are not supported yet.")
(base32
"1cpjqnrviwflz150g78iir5ndrp3hh7a93zbp4dwbg6sb2q141p2"))))
(build-system go-build-system)
- (native-inputs
+ ;; From go-1.10 onward, "pkg" compiled libraries are not re-used, so
+ ;; when this package required as input for another one, it will have to
+ ;; be built again. Thus its CGO requirements must be made available in
+ ;; the environment, that is, they must be propagated.
+ (propagated-inputs
`(("pkg-config" ,pkg-config)
("taglib" ,taglib)))
(arguments
- `(#:import-path "github.com/wtolson/go-taglib"))
+ `(#:import-path "github.com/wtolson/go-taglib"
+ ;; Tests don't pass "vet" on go-1.11. See
+ ;; https://github.com/wtolson/go-taglib/issues/12.
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key import-path #:allow-other-keys)
+ (invoke "go" "test"
+ "-vet=off"
+ import-path))))))
(home-page "https://github.com/wtolson/go-taglib")
(synopsis "Go wrapper for taglib")
(description "Go wrapper for taglib")